Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   Well... That was not a good idea.. (http://www.bimmerfest.com/forums/showthread.php?t=668355)

Mr.750 01-06-2013 12:39 PM

Well... That was not a good idea..
 
Alright so a few weeks ago my car was running low on anti-freeze and not knowing BMW made special anti-freeze, just filled my car full of John Deere tractor anti-freeze. Now a few weeks later the computer is telling me my anti-freeze level is low so I called and found out it takes a special kind. So my question is what should I do? Should I stop driving the car and order some BMW to put in it when the anti-freeze comes? Should I drain it then re-fill it with BMW anti-freeze? Should I continue putting John Deere anti-freeze in it? Any advice would be appreciated. Thanks!

MMME30W 01-06-2013 01:06 PM

Woah. No idea what tractor anti freeze is composed of. Google search?

Anyways, does the 7er have an expantion tank? Might be idea to drain that, then refill, then idle the car. If you did that three times, seems like most of it would be gone?

But yeah, no idea what that stuff would do. If it were mine, I'd get it replaced.

M4XBMW7 01-06-2013 02:24 PM

Yah these cars are very sensitive and do require their own antifreeze , what i would do if i was you , would be taking it in for a coolant service by a BMW dealer , $200 bucks they will flush and clean all the contamination ( if there is any ) etc and let you know if there's anything wrong . Just my .2c

KaileSvick 01-06-2013 05:53 PM

You may possibly have a bad coolant level sensor. To my knowledge its just a float in the expansion tank that measure coolant levels. Or you may just be low. My .02

7Rage 01-08-2013 10:19 AM

I cant see there being a sensor that detects a special compund or ingredient in the coolant so the car can tell if it bmw or other brand.... if there is tho, jeez:tsk:..

and if you dont have a leak... then you are low maybe because there is air in the system? and it appeared full but when turned on the air went to the radiator..

My question is why does it keep getting low....

try filling is with distilled water... that way you arent putting the wrong antifreze in and damaging anything.. plus its probably cheaper:thumbup:...


If it is full still then bad sensor seems probable...

or you can just go to the dealer:mad:


All times are GMT -7. The time now is 06:09 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms