Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E30 (1982 - 1993) (http://www.bimmerfest.com/forums/forumdisplay.php?f=96)
-   -   M10 Running rich, bad MPGs, misses at high RPM (http://www.bimmerfest.com/forums/showthread.php?t=668822)

FenderBender 01-08-2013 04:10 PM

M10 Running rich, bad MPGs, misses at high RPM
 
Alright guys, winding down some issues with my car. In my E30 build thread, you can catch up to what all I've done.

The rundown:

84 318i, M10

Didn't run when I bough it, replaced a bunch of stuff and finally the computer fixed it.

New:

FPR
Fuel filter
Converted to single fuel pump
Plugs (may replace again)
Distributor cap, rotor, wires
Valve cover gasket
Misc. van lines
Two different AFMs
Air filter
IAC
Injectors
Cheap coolant temp sensor
Used DME
O2 sensor
Adjusted valves

Misc. info

Has small radiator leak

MPG calculated today was 18 mpg, I've had it up to 23mpg, 90 percent highway though.

Misses at high rpms, around 5k I'd say, it won't rev past that with a load. In neutral I believe it will hit the rev limiter.

I'm told it smells rich, I can't smell it because I drive it all the time lol and am used to it I suppose.


The car runs pretty well, the idle was very very lopey, but it's 90 percent fixed now from the new IAC. Will idle at 800rpm ish when warmed up.


What's next? Could a TPS cause this? I doubt both AFMs are shot but who knows? Cheap coolant temp sensor gone bad?


I are confused.

downhiller 01-08-2013 05:15 PM

tps can do that. say its sending a bad signal, it could be WOT when you only have the pedal say 1/2 way. i would check that and the fuel pressure.

FenderBender 01-08-2013 05:38 PM

I think someone told me I can drive it with it unplugged? (tps)

Anyone know the specifications to test it?

Sent from my SCH-I605 using Bimmer App

downhiller 01-08-2013 06:37 PM

i dont know if the car drive with it unplugged. its either gunna be running way rich or lean depending on how the signal is set up.

measuring, couldnt tell you. for the short search i did, i couldnt find anything. but i didnt try too hard. trying to get ready for a 3000 mile trip on the motorcycle

Nick323 01-09-2013 04:38 AM

Quote:

to get ready for a 3000 mile trip on the motorcycle
you only need a Cedit card & some comfy leathers ;)
Enjoy it :)

FenderBender 01-09-2013 05:15 AM

Also, sometimes now when im driving let's say at 50mph, I rev match shift it and it losses power and or shuts off. After a few seconds I'm able to rev it up again.

Weird....

Sent from my SCH-I605 using Bimmer App

First time 01-09-2013 08:40 AM

I (as you know) have a '84 318i and dont get that great of mileage either. I would test the TPS. Also my afm does the same jumping around yours does. Im sure that is playing a huge part in fuel consumption. I too have replaced near the same things you have. However when i rev match i dont experience what you say.

I know that i need to time my car correctly though. I just did it by ear. Misses slightly around 47-5 also.

Considering the age of our cars i always have this hunch that the distributors are old and tired but i havent took the time to test mine yet. The coils are fairly bulletproof in my experience with these cars.

FenderBender 01-09-2013 06:04 PM

Thanks for the info guys.

I think I may have figured at least one issue out. I was fiddling with the car, check the TPS (PITA, couldn't really tell if it was ok or not) and checking for vac leaks. I hear a slight hissing noise near the firewall all the time but I can't seem to pin point it. Anyway I was moving wires around, and the fuel return line when the idle started changing. So I moved the return line and sure enough, changed the idle, if I move it a certain way, it will die. If I move it another way, it will idle right at 700 rpm. Part of the line is almost rock solid.


So tomorrow I'll replace that whole line and see what happens.

BmwMan92 01-11-2013 12:19 PM

Are you certain your having something wrong? My 318 would stutter under load because the engine is weak. Barely 100 hp in perfect running condition

FenderBender 01-11-2013 03:33 PM

Quote:

Originally Posted by BmwMan92 (Post 7306423)
Are you certain your having something wrong? My 318 would stutter under load because the engine is weak. Barely 100 hp in perfect running condition

Lol, no that's not it. I believe I fixed the issue, fuel mileage seems to be up as well, will know for sure when I fill the tank up.



Replaced that fuel return hose, turns out that wasn't the issue, although the old hose was hard and cracked.

When I was wiggling that it was moving a ground wire that wasn't attached! Fixed that and all is well (so far) it idles perfect and doesn't hesitate or anything.

downhiller 01-11-2013 10:08 PM

Quote:

Originally Posted by Nick323 (Post 7300415)
you only need a Cedit card & some comfy leathers ;)
Enjoy it :)

no leathers. using textile jacket and jeans, and a mix of leather and textile gloves. need to get a credit card though. it gunna be hot and hopefully not too much rain


All times are GMT -7. The time now is 01:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms