Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E39 (1997 - 2003) (http://www.bimmerfest.com/forums/forumdisplay.php?f=103)
-   -   Engine Failsafe Program-Idle Valve-low response from Accelarator (http://www.bimmerfest.com/forums/showthread.php?t=669099)

saqibkhan 01-09-2013 10:26 PM

Engine Failsafe Program-Idle Valve-low response from Accelarator
 
Guyz,

I need your urgent help please, I recently changed MAF and Cam Sensors with Fuel Pump .... and now my car is giving Error Code for Idle Control Valve ..... I tried changing that also but still error is same .... Moreover, after driving a mile, getting message of Engine Fail Safe Prog on Dash and instantly when I get this message the response from accelrator padel goes low ..... I mean Even I push the pedal to full, the car accelarates very very slow .... can anybody tell me what could be the reason ... Car is with my mechanic and he just call me to say he wants to repair its catalytic converters ...... i tried finding out on previous forums also but couldn't find anything .... could you guyz explain me in layman language please as I am new to BMW world ....

Thanks alot in advance

saqibkhan 01-09-2013 10:27 PM

Shoot I forgot to give my car's background ... .very sorry for that .... its E39 530, 2002 done 150,000kms .....

edjack 01-09-2013 11:17 PM

Tell your mechanic to explain the connection between the catalytic converters and the idle control valve. If he can't, find another mechanic who can.

saqibkhan 01-09-2013 11:32 PM

You are right bro!
I inquired him and he said there are total of three errors, one is regarding to catalytic converter, other is ICV and Oxy-Sensors .... he already tried changing ICV but still the problem remain same .... so he is now moving to catalytic converter saying that may be the filter is chocked ..... but still I dont know the connection between that filter and my problem of getting Engine Fail Safe Prog and least response from accelerator padel.

saqibkhan 01-09-2013 11:36 PM

I really am fed of all this !!! running after mechanics and getting most unfruitful results ..... I stays in UAE and here finding a good mechanic is as easier as to hang yourself ..... the agency itself sucks .... if I took it to agency, i will need to pay thousands of dollars and I am quite sure that also for nothing .... seeking advises from you guyz ... honestly .... I need to diagnose it myself and then ask my mechanic to replace that particular item ... that is all I can expect from mechanics here ....
Your useful advises will really be appreciated .....

poolman 01-11-2013 03:42 AM

Removed the trhottlebody and give it a good cleaning--that might be all that is wrong with it--after 150k miles it probably has carbon build up and just needs cleaning for the part to work correctly.

saqibkhan 01-11-2013 11:35 PM

Thanks Poolman, it was indeed the problem, I tried changing the whole throttle body also .... My mechanic fixed Catalytic Converters ... now all the errors are cleared ..... but the problem in the car still is same ..... after few kms it gives the error of Engine Fail-Safe Prog and after that accelerator of car dies ...... If I am on a speed of 100km/hr, I can continue with the same speed but when I bring the car to stop and pull it up again, it takes too much time to again get back to 100 kms/hr ..... my mechanic, I feel is unable to understand the problem .... the only error I am getting now is ¤dle speed control valve-Mechanical Fault .....He already tried replacing the Valve but still no success ....
Please friends pull me out of this depressing stage .... I recently bought and it is really driving me craczy .... Though I prefer to cry in BMW rather than smiling in Toyota but I need to get out of it before my tears get dried .....
Thanks in advance

poolman 01-12-2013 05:37 AM

If you tried to use a different throttlebody, that won't work--they have to be programed to the car when installed--if you did that--it might cause the one that was in the car to need reprogramed--Put your old throttlebody back in the car--if it still doesn't work--take it to the dealer and have them hook up the GT1 scanner and see what it needs--best I can do for you--good luck
Might try this also--carry a code reader with you for awhile and when the code comes up--read and erase the code--that will keep the problem of engine shutdown away

tomjrau 01-12-2013 08:04 PM

I struggled with the engine failsafe mode too where the throttle pedal would become unresponsive as the engine would oscillate between 800-1500rpm. I tried replacing, then cleaning the MAF without success. Finally, I just did a throttle reset and seems to have fixed the problem. No issues for last 13k miles. Put key to ignition 2 for 10 secs, then off 10 secs, then start car.

saqibkhan 01-12-2013 09:42 PM

Guyz .... I did what you said ... I asked my Mechanic to reset it properly also I myself did as advised by Tomjrau ..... and to my surpise, no message since last evening I have drove about 30 miles and no message till now :) :) :) I feel relieved .....
Hopefully, it wont come again ..... you guys rock :) :) :)
Thanks alot ... thank you very very much .... my first experience of being on any forum turned out great ..... thank you so very much ......

saqibkhan 01-17-2013 03:42 AM

guys ..... Its to reconfirm ..... Its been a week almost .... I drove about 1000 kms ..... and I am not getting any message of Engine Fail Safe Program ...... Hence,

If anybody reading this post later, facing the same problem of gettting message of Engine Fail Safe Prog and once the message arises accelaration of car dies instantly and drasctically .... then you must try replacing the Throttle Body and get it reprogrammed ..... Reporgramming/Resetting is mandatory otherwise you still will face the problem ..... I have wrote that on my chest, replacing anything needs resetting :) :) :)

Good Luck and Enjoy your Ride ....

tomjrau 01-23-2013 06:34 PM

Or in my case, I didn't replace any components and just did the throttle reset procedure which solved my issues.

Glad it helped you out.


All times are GMT -7. The time now is 08:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms