Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E34 (1989 - 1995) (http://www.bimmerfest.com/forums/forumdisplay.php?f=102)
-   -   1995 E34 540i Engine knock, and rough idle (http://www.bimmerfest.com/forums/showthread.php?t=669408)

zfxpE34 01-11-2013 10:44 AM

1995 E34 540i Engine knock, and rough idle
 
I just bought a bmw 540i 1995
it has a knock or some kind of noise
http://youtu.be/JudW1O9vUco

please let me know what you guys think!

Monsignor 01-11-2013 10:48 AM

It says "video unavailable"

zfxpE34 01-11-2013 10:51 AM

check it in 4 minutes the video has finished uploading yet, my apologies.
also will be posting a video of when it's driving (mind you is absolutely perfect)

It's good to go!

Monsignor 01-11-2013 11:03 AM

sounds like it could be a loose spark plug. Get in there and torque them down. If you have a torque wrench the spec is
Spark Plug to Cylinder Head . . . . . 30 Nm (22 ft-lb) (Bentley, page 020-11)
If you need to replace them they are Bosche F7 L DCRs (Bentley, page 020-11)

Also make sure the coil boots are in good shape and not damaged

BMR_LVR 01-11-2013 01:48 PM

Quote:

Originally Posted by Monsignor (Post 7306234)
sounds like it could be a loose spark plug. Get in there and torque them down. If you have a torque wrench the spec is
Spark Plug to Cylinder Head . . . . . 30 Nm (22 ft-lb) (Bentley, page 020-11)
If you need to replace them they are Bosche F7 L DCRs (Bentley, page 020-11)

Also make sure the coil boots are in good shape and not damaged

+1 :thumbup:

Monsignor 01-11-2013 02:02 PM

OP has confirmed to me via text message that he will tackle this in the AM and post his results.

I'm confident this is the fix.

zfxpE34 01-12-2013 12:30 PM

This was not it.
Mechanic believes lifters are ticking and needs oil change and vaccuum leak.

Sent from my SPH-L710 using Bimmer App

Monsignor 01-12-2013 12:47 PM

Did you tighten them?

Sent from Joe's Galaxy Tab 2 via BimmerApp

zfxpE34 01-12-2013 01:16 PM

Quote:

Originally Posted by Monsignor (Post 7308579)
Did you tighten them?

Sent from Joe's Galaxy Tab 2 via BimmerApp

Yes, I did.

Monsignor 01-12-2013 01:37 PM

Maybe the oil pump is actually faulty and its not lubricating the top end properly...

Sent from Joe's Galaxy Tab 2 via BimmerApp

zfxpE34 01-12-2013 01:42 PM

The mechanic(Ferman Mechanic for 18 years) who looked at it, said my oil NEEDED to be changed.
Said the car was drivable, he stated it was a tick not a knock.

So he's going to do it tonight, and after the car has been sitting for a year, says it'll probably clear up, and he believes the oil pump is fine, but I may just have it changed anyways.

BMR_LVR 01-12-2013 02:41 PM

Can't remember. Does your engine have vanos? My E36 vanos knocked for a short while after it had been sitting for 6 months.

zfxpE34 01-12-2013 02:52 PM

I believe it does not have vanos..

Monsignor 01-12-2013 03:22 PM

Quote:

Originally Posted by BMR_LVR (Post 7308799)
Can't remember. Does your engine have vanos? My E36 vanos knocked for a short while after it had been sitting for 6 months.

I don't believe m60 ever had vanos. The M62 did

Sent from Joe's Galaxy Tab 2 via BimmerApp

zfxpE34 01-18-2013 10:50 AM

Replaced ALL plugs

narrowed it down to bad Coil on Cyl #6 :), waiting on Advanced to get it in tomorrow!
I'm QUITE confident this is it!

Price of car:3500
Spark plugs: $40
New Oil + Filter: $65 (Solved Oil pressure light)
New windshield Wipers: $16
New coil $75

I think I'm doing well.

supertech777 01-18-2013 05:02 PM

Quote:

Originally Posted by BMR_LVR (Post 7308799)
Can't remember. Does your engine have vanos? My E36 vanos knocked for a short while after it had been sitting for 6 months.

Correct me if I'm wrong please , but I thought e36 's only came in 4 cyl.and 6cyl ? And if they did come in a m60 I want one :D

Sent from my Desire HD using Bimmer App

BMR_LVR 01-18-2013 05:34 PM

Quote:

Originally Posted by supertech777 (Post 7323114)
Correct me if I'm wrong please , but I thought e36 's only came in 4 cyl.and 6cyl ? And if they did come in a m60 I want one :D

Sent from my Desire HD using Bimmer App

You're correct in that they came with only 4 and 6 cylinder engines. But, one of the 8 cylinder engines (M62 per Joe) came with vanos.

I could not remember which V8 had it. If OP's did, it could be a possible cause of the noise. I related it to my E36 because, when it was down for 6 months or so, the vanos made a very similar noise for a short time after the first start up.

supertech777 01-18-2013 06:16 PM

Quote:

Originally Posted by BMR_LVR (Post 7323182)
You're correct in that they came with only 4 and 6 cylinder engines. But, one of the 8 cylinder engines (M62 per Joe) came with vanos.

I could not remember which V8 had it. If OP's did, it could be a possible cause of the noise. I related it to my E36 because, when it was down for 6 months or so, the vanos made a very similar noise for a short time after the first start up.

Ah I see , man but what a beast a e36 would be if it did come with an option like a m60 , I was about to look for one Steve LOL ... Thanks for clarifying it for me Steve ill delete it of my wish list ! :)

Sent from my Desire HD using Bimmer App

air_cooled 01-22-2013 09:24 PM

Quote:

Originally Posted by supertech777 (Post 7323244)
Ah I see , man but what a beast a e36 would be if it did come with an option like a m60 , I was about to look for one Steve LOL ... Thanks for clarifying it for me Steve ill delete it of my wish list !

Well you can just go add it back on the list. Alpina made five E36 with the M60 engine.
Alpina B8 4.0
http://www.alpina-archive.com/?cat=399


All times are GMT -7. The time now is 09:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms