Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E30 (1982 - 1993) (http://www.bimmerfest.com/forums/forumdisplay.php?f=96)
-   -   E30 won't start (http://www.bimmerfest.com/forums/showthread.php?t=670085)

bradi65 01-14-2013 02:49 PM

E30 won't start
 
hay guys pretty new to this site ,but with a dodgy e30 i think i mite get to know everyone quite fast.

Have just fixed a coolant hose as it had a hole and was causing the car to overheat. now when i tried to start her up and test out my new hose it turned over but wont start. would like to know everyone's thoughts maby common problems. i suspect fuel/ fuel pump or maby the starter coil? i haven't really tested anything yet as its pooring down and i dont have a garage =[. i have tested the fuel pump relay and it seems ok.

Titan_Omega 01-14-2013 03:03 PM

my car has this issue currently but they have tested and ruled out

Fuel pulp
fuel pressure
injectors
the ECU
Crank position sensor
the fuel relay ( its located on the driver side wheel well )

it gets spark but they suspect its too weak so they are replacing the ignition system its the original system so if thats the case id check your distributor cap and post a pic of it cause im thinking thats what it is with my car.

I recommend you check all of those

bradi65 01-14-2013 06:09 PM

okay cool . so i can pull the distributor cap off with out anything going wrong ? like is there any timing i should be careful of or take notes about or is it just clip on clip off sort of thing.

Titan_Omega 01-14-2013 06:11 PM

No just take the cap off and thats it dont lose any of the bolts to put it back on if its not the issue

BMWFatherFigure 01-14-2013 10:24 PM

Did any electronics/electrics get wet in the coolant system fix. Check those things.

bradi65 01-15-2013 01:30 PM

i dont think that they did. i checked for spark last night and thats algood. but i took out the main relay and noticed alot of rust inside so ill get a new one today, could the problem be as simple as a faulty relay ?

bradi65 01-15-2013 01:30 PM

i did not take the disrubitor cap off as i gessed if theres spark then its probly okay ? or should i still check

bradi65 01-16-2013 12:32 PM

okay so last nite i think i got alot closer to finding out the problem, i managed to start it after cranking it for about 10sec and holding my foot flat on the accerlator pedal untill eventy it coughed a bit and stared up , it ran fine didnt over heat and wen i turned it off thn back on again it started fine. does this mean i have a dodgy fuel pump ? or blocked filter? or both lol

e30325i 01-16-2013 03:06 PM

wld change the filter first..if it cranked after you held the pedal down a while then ur problem is somewhere in the fuel system i would think..check the spark plugs as well

bradi65 01-16-2013 03:29 PM

ordered a fuel filter today so hopefully will get it in by the weekend. i was going to change the spark plugs, is there a specific band the would be best or will anydo ? will i have to set the gap or will the come pre set. sorry for all the questions.

hornhospital 01-16-2013 03:31 PM

Bosch or NGK plain copper plugs. Stay away from the four-prong versions.

bradi65 01-16-2013 03:39 PM

cool thanks for that . this will probably sound stupid but what does 4 prong mean i know you get 2 prong and 4 but don't understand what it actually means.

Nick323 01-17-2013 12:25 AM

Fuel pressure drop off
 
Quote:

Stay away from the four-prong versions
I 2'nd 3'rd &... this :thumbup:
Bunch of advertising hype Bull**** (I hope my wife, who worked in the advertising industry for 12+ years, does not read this ;)).
2- prong or V-groove make sense to an extent.
I don't know why, but the Super-4 sometimes makes cars run worse, such as the Toyota F-series engines found in the old Land Cruisers :dunno:

But getting back to your problem.
It only starts, after cranking for some, while when it has stood for a period ?
Then it usually is the fuel pressure dropping to such an extent in the fuel line, that it first has to fill again.
Culprit is either the Fuel pressure regulator leaking or (more likely) the one-way valve in your fuel pump.
The chassis pumps seem to be Ok on this, but the one in the tank often goes fauly ????

e30325i 01-17-2013 07:30 AM

always go ngk plugs..and he said he has to hold the pedal down a while 2 so maybe somethings blocking the gas from getting where its suppose to be in the filter..but let us know when you switch them out

bradi65 01-17-2013 01:03 PM

fuel filter just arrived . i will put it in after work and let you guys know what happens. its good to be able to talk to people actually interested rather than a sales man who just want to sell me a $650 fuel pump !!!!!! lol

BMWFatherFigure 01-17-2013 06:28 PM

If possible check fuel pressure in the rail.

bradi65 01-18-2013 06:01 PM

put the filter in but no change, think it the pump as when i turn the key i cant hea it pumping or anything

BMWFatherFigure 01-19-2013 10:11 PM

Checking back on this - could be main relay in rusty socket. Clean that out a lot!

bradi65 01-23-2013 05:34 PM

will clean out the relay socket contacts tonight i did replace that1. how do i post a pic of the motor ? was going to put it up if it helps but not sure how to add it to the post lol

bradi65 01-23-2013 05:43 PM

3 Attachment(s)
Attachment 358958

Attachment 358959

Attachment 358960

found out how lol.

_Ethrty-Andy_ 01-24-2013 12:00 AM

take fuel line feed off and see if petrol comes out when you turn the key to ON but before starting. not sure what non-BMWs are like, but these cars prime for a second or two before starting. that will help determine if the fuel pump is working, though it could still be non working up to spec. there is a filter on the tip of the pump that can get blocked too IIRC, i can picture the E34 pump but been a while since i looked at an E30 one.

bradi65 01-24-2013 07:26 PM

okay i have got my hands on a 2nd hand fuel pump so I'm going to put that in today, pretty sure its the problem. i cant here it pumping when i turn the key, haven't checked for voltage on the 2 pin connector but i have on the 3 pin , does anyone know what the 3 pin connector is for?

BMWFatherFigure 01-27-2013 05:06 AM

Fuel level sender

bradi65 01-29-2013 11:02 AM

lol i should have thort of that , the cars all going now seems pretty good but some times after it hasnt been started in awhile you have to put you foot on the gas before it starts up , after that it runs fine through thr revs, any ideas of to what mite cause this ?

Nick323 02-05-2013 02:00 AM

Anyone know where the non-return valve is located, in the in-tank pump on the 323 ?
mine sometimes holds pressures & other times....


All times are GMT -7. The time now is 01:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms