Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E39 (1997 - 2003) (http://www.bimmerfest.com/forums/forumdisplay.php?f=103)
-   -   missing knock sensor (http://www.bimmerfest.com/forums/showthread.php?t=671929)

CurtSmall 01-23-2013 05:15 PM

missing knock sensor
 
Greetings from the Black Hills. I have newly aquired a 2000 528i sport with the I6. I have been replacing sensors, and I'm down to the knock sensors. I went to install the new sensors, and I found the harness side recepticle, but no knock sensors! ...anywhere! And this would explain why I keep getting that code. My problem is I have no idea where the mounting points are. I see several threaded female openings on the block, and from the viewing angle I have, I don't see any obvious ones to start with. Having searched the forum for these questions with no luck, I decided to post these 3 questions:

Where are the mounting holes for the two knock sensors?

If I need to remove other components to install the new sensors, is there a DIY thread on here?

Does anyone know the size/thread cut of the mounting bolts? (I'm pretty sure mine are MIA)

Thanks in advance for any beta that can be shared.
Curt

geargrinder 01-23-2013 05:44 PM

Curt - i just posted on the other KS thread... Torque for those needs to be exact (or at least as good as you can manage) for them to work properly. Id fire up TIS for you but my car computer is frozen solid in the back of my audi in the airport parking garage. I would consider getting the real Oem dealer bolts to be sure they mate up and apply force properly. If you have a good junkyard should be an easy snag too... Sorry cant help on location or specs at the moment.

JC

pleiades 01-23-2013 06:34 PM

Quote:

Originally Posted by CurtSmall (Post 7333417)
Greetings from the Black Hills. I have newly aquired a 2000 528i sport with the I6. I have been replacing sensors, and I'm down to the knock sensors. I went to install the new sensors, and I found the harness side recepticle, but no knock sensors! ...anywhere! And this would explain why I keep getting that code. My problem is I have no idea where the mounting points are. I see several threaded female openings on the block, and from the viewing angle I have, I don't see any obvious ones to start with. Having searched the forum for these questions with no luck, I decided to post these 3 questions:

Where are the mounting holes for the two knock sensors?

If I need to remove other components to install the new sensors, is there a DIY thread on here?

Does anyone know the size/thread cut of the mounting bolts? (I'm pretty sure mine are MIA)

Thanks in advance for any beta that can be shared.
Curt

I Googled and got a link to an M54 engine block with the sensors still attached. Should be the same for your M52TU. These two sensors share one plug and are buried underneath the intake manifold. Not sure how easy it will be to get to them....

http://forum.e46fanatics.com/showpos...&postcount=199

bluebee 01-24-2013 04:51 AM

Quote:

Originally Posted by CurtSmall (Post 7333417)
Where are the mounting holes for the two knock sensors?

Type /knock sensor F3 into the bestlinks, and this comes up, which may help:
- How to understand the piezoelectric knock sensor operation (1)

In addition, if that doesn't help, there 'should' be a photo of the knock sensor in-situ here:
- Where to find in situ pictures of common parts of the M54 engine (1)

http://bimmerfest.com/forums/attachm...1&d=1351004682

Please help out by snapping a photo of each of the locations of your knock sensors so that the rest of us benefit (personally I've never dealt with them so this is the best I can offer).

CurtSmall 01-24-2013 12:15 PM

Ok... so the only DIY for the knock sensors says remove PS reservoir and oil filter cap.. that's it. After removing those items, I still cant even see the knock sensors. If anyone has ever replaced their knock sensors, could you share some insite? I've started taking pictures of this process to make sure that I can post this start to finish replacement for future DIYers. Again, 2000 528i sport, I6.

aspensilver540 01-24-2013 12:41 PM

I don't know or have that engine but in the above you can see two intake ports, the above pic is with the intake manifold removed. Not sure if you have to remove it on this car to access knock sensor, you do on the V8. You need to look near the intake manifold ports

CurtSmall 02-08-2013 05:47 PM

Wow what a project! For those misfortunate souls that need to replace their KS, I have bad news. You have to remove the intake to access them. With some difficulty, you will be able to get to the front one by removing some hoses and the sensor "hub", but it is not possible to get to the rear one with the intake on. I took pics that I will post soon.

I was right when I said I found the receptacle end of the KS. However my KS wasn't missing. In fact, the KS I eventually found looks brand new.... it just wasn't plugged in! I would have still had to pull the intake tho, due to the incredibly short lenght of the KS wire. Plugged it in, put everything back together, and the car runs great.

now on to BlueBee's FSU thread to try and figure out why my 3 week old battery goes dead every night.....


All times are GMT -7. The time now is 02:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms