Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   BMW E66 problem when refueling (http://www.bimmerfest.com/forums/showthread.php?t=672235)

See-5 01-25-2013 01:47 AM

BMW E66 problem when refueling
 
Hi


I had this problem for over a year now :tsk:

http://www.youtube.com/watch?v=jWZFTZuuQyU

skip to ( 1:05 )

When refueling the filler thingy clicks at a random tank level ( mostly less than a half ) while it normally should only clicks if the tank is fully filled


And therefore as you can see it takes 4 minutes to refill the tank 0_0


What do you think is the issue ?


the computer gives this fault code :

2A13 DMTL Leak Diagnosis pump, activation



Thank you

See-5 01-25-2013 01:54 AM

Is this the solution http://www.bimmerfest.com/forums/sho...d.php?t=555805


?

See-5 01-27-2013 04:23 AM

up

gmcclintock 01-27-2013 07:13 AM

Yes I think that thread is the solution, I had the same problem a while back and I had the vent valve replaced and never had that issue since. You might want to show that video to your SA and he/she will tell you exactly what is causing the problem.

See-5 01-27-2013 12:13 PM

Quote:

Originally Posted by gmcclintock (Post 7341059)
Yes I think that thread is the solution, I had the same problem a while back and I had the vent valve replaced and never had that issue since. You might want to show that video to your SA and he/she will tell you exactly what is causing the problem.



Thx ! :thumbup:

See-5 01-28-2013 08:11 AM

So it isn't the Vapor canister ?

http://www.youtube.com/watch?v=ksHqjydj5bA



It costs 407 $ :\

See-5 01-28-2013 10:36 AM

this part is what the fault codes described !

http://www.eeuroparts.com/Parts/2934...p-16137193479/


I must check with the workshop to ensure though

meangreen94z 10-23-2014 10:37 AM

It sounds like you top your tank off. When the pump clicks once, that's it. If you top your tank off fuel will spill into the canister and saturate the charcoal filter and ruin your DMTL pump. You won't be able to pump fuel normally and it will set a fault sometimes for the pump.

cl1987 10-23-2014 06:01 PM

Quote:

Originally Posted by See-5 (Post 7343096)
So it isn't the Vapor canister ?

http://www.youtube.com/watch?v=ksHqjydj5bA



It costs 407 $ :\


Where is this hose on a bimmer 07 750i. I think i need to clean mine out.

See-5 01-22-2015 02:10 PM

Quote:

Originally Posted by meangreen94z (Post 8662955)
It sounds like you top your tank off. When the pump clicks once, that's it. If you top your tank off fuel will spill into the canister and saturate the charcoal filter and ruin your DMTL pump. You won't be able to pump fuel normally and it will set a fault sometimes for the pump.

I have never did that for your info . Even if I did so I don't think it should be that bad

See-5 01-22-2015 02:12 PM

Its been three years now and I am still having this problem !


I replaced the carbon filter and the leak diagnostic pump once and the problem came back on after two months.


I use 95 octane premium gas only.


Next week the mechanic will open the car's computers to investigate this !

See-5 01-22-2015 02:14 PM

Quote:

Originally Posted by cl1987 (Post 8663733)
Where is this hose on a bimmer 07 750i. I think i need to clean mine out.

You can find the carbon filter inside the rear right fender . Just open the fender cover after taking out the wheel and you will see it at the top .


All times are GMT -7. The time now is 07:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms