Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E46 (1999 - 2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=98)
-   -   Weird engine problem (http://www.bimmerfest.com/forums/showthread.php?t=673940)

xpro6000 02-02-2013 02:55 PM

Weird engine problem
 
Hi guys

This problem sometimes happened when my engine idled but it has become worst to a point that it's happening almost all the time. I'll try to describe the problem as best as I can.

When I turn on the car cold, it runs fairly good until I give it gas and it loses power and the engine starts to sounds like it's not running on all 6 cylinders. After a while that the car runs the power gets so low that if a heel is steep I have to give it full throttle in order to get any acceleration. The coils and spark plugs were changed about 7 months a go and I tested them by unplugging each coil while the car was running and the engine sound changed as I unplugged and plugged them back in. Fuel injectors were also changed yesterday.

Sometimes when I'm driving at fairly constant speeds in the highway engine returns to normal but after giving it full throttle the problem returns and the engine loses power and feels as if it's not running on all 6 cylinders.

I have run out of ideas. I also made a video that you can hear the engine while the car was in my garage.

http://youtu.be/ACz8mSXH6CU


If you guys would know what it could be please let me know.

SJBimmer 02-02-2013 04:25 PM

Have you ever changed your fuel filter? Any codes? Fuel pump making any strange noises?

xpro6000 02-02-2013 04:34 PM

Quote:

Originally Posted by SJBimmer (Post 7355396)
Have you ever changed your fuel filter? Any codes? Fuel pump making any strange noises?

I have never changed the fuel filter, I don't have any strange noises from the fuel pump. So the next thing I should try is the fuel filter? What about the MAF? could the MAF be the problem?

Fast Bob 02-02-2013 04:44 PM

CODES, man....ya *gotta* get the codes scanned ! Without that, you`re shooting in the dark, and you`ll never get to the root of the problem.

TannerT 02-02-2013 07:12 PM

Might be fuel related but without codes it could be the pump filter or regulator

Sent from my PantechP9060 using Bimmer App

xpro6000 02-02-2013 07:21 PM

I will place an order for a Bluetooth OBD II reader. I will update this thread when I receive it and get the codes.

SeaRay 02-02-2013 07:41 PM

Just run by AutoZone. They will scan it for free.

xpro6000 02-02-2013 07:47 PM

Quote:

Originally Posted by SeaRay (Post 7355744)
Just run by AutoZone. They will scan it for free.

I usually did that, but I will use this for myself, friends and relatives as well so it will be useful, I found a very good one selling for $23 on Amazon which was hard to pass. It connects to your smartphone and gives all sorts of information.

xpro6000 02-08-2013 03:41 PM

I received the OBDII reader and the codes are: P0313 and P0302 which from my research means misfire with low fuel. So I'm thinking about changing the fuel filter. I've heard some 325s have the filter in the fuel tank. How can I make sure my car has the fuel filter outside of the tank? is the only way to find out to jack up the car and look under the car?

Fast Bob 02-08-2013 06:07 PM

This should give you an idea of how to perform a filter swap.

http://www.youtube.com/watch?v=B4T_pVvXtps


All times are GMT -7. The time now is 10:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms