Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X3 F25 (2011 - current) (http://www.bimmerfest.com/forums/forumdisplay.php?f=158)
-   -   Oil Sensor accuracy???? (http://www.bimmerfest.com/forums/showthread.php?t=704432)

ctlyankee 06-22-2013 05:36 AM

Oil Sensor accuracy????
 
Two months ago, while driving, a warning flashed that I should add a quart of oil ASAP. I had the oil changed only 10 weeks prior, so I doubted that it would need oil already. I pulled over and shut the engine off then restarted. At that point I ran the check oil level and it showed it was at the max. Yesterday the warning came on again, so I pulled over to check the level after I restarted it said the oil level was OK but only showed about 1/4 over the min. So I stopped at the dealership on my way home and they put a quart of oil in but the level still shows about 1/4 over min. After driving today I checked the level again and the level has not changed. I really wish it had the "old fashion" dipstick to check oil levels. I read a few other posts on this problem but I could not find a definitive outcome. How many others experienced this problem? BTW: The representative at the dealership stated it was not unusual for BMWs to need oil added between changes. - I find that somewhat disconcerting.

The X Men 06-22-2013 06:58 AM

Sounds like you have a intermittent oil level sensor problem rather than a accuracy problem or an actual oil leak problem. If this problem occurs again, I would ask your dealer to check the actual amount of oil you have in the engine by draining and measuring the volume.


All times are GMT -7. The time now is 11:27 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms