Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X5 E53 (1999 - 2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=22)
-   -   Need help with power brakes and P2187 (http://www.bimmerfest.com/forums/showthread.php?t=708821)

LantanaTX 07-14-2013 12:02 PM

Need help with power brakes and P2187
 
Hello, I am new here and just purchased a 2004 X5 4.4 I love the car and it looks like new. I got it cheap from a wholesaler because it has a few issues I am working through. A couple of days ago, the check engine light came on with P2187 (left bank lean) and at the same time the brakes got scary. The brakes at first feel fine but lose power assist before coming to a complete stop which means you really have to stand on the pedal to get it to come to a complete stop. I am checking out the obvious but wanted to see if anyone has ever experienced this and what the fault was. Thank you!

upallnight 07-17-2013 04:23 PM

Sounds like you have a vacuum problem at the intake manifold or booster. Check all the hoses for cracks.

LantanaTX 07-17-2013 06:48 PM

Quote:

Originally Posted by upallnight (Post 7716809)
Sounds like you have a vacuum problem at the intake manifold or booster. Check all the hoses for cracks.

I checked the hoses and also see that it does not get vacuum from the manifold like billions of other cars. it has a vacuum pump that runs of the right bank cam. The problem is either the pump or the booster. It isn't easy to know which part failed but I have read the pumps are prone to fail. with two new seals it can be rebuilt. I ordered the seals and will rebuild the pump. If that doesn't work a new booster will be next.


All times are GMT -7. The time now is 11:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms