Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X5 E53 (1999 - 2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=22)
-   -   2003 BMW X5 E53 "Engine Failsafe Prog" Error Light*** (http://www.bimmerfest.com/forums/showthread.php?t=723073)

TreySamuels 09-19-2013 10:36 PM

2003 BMW X5 E53 "Engine Failsafe Prog" Error Light***
 
Excuse me if this has been said before but I am baffled at this issue with the X5. I've owned this vehicle about 3 months now and have been dealing with a dreadful "Engine Failsafe Prog" error message light where all of the engine dashboard lights come on and I usually pull over and wait for about a minute and start up again and nothing. I bought it pre-owned, carfax is good, got about 120K miles. This issue seems to have started when I replaced the old battery with a brand new one a month after purchasing.

Took it to O'reilly as the service engine light is now on. The error codes were p0172, p0175 and p1500.

Now I don't have any experience with the X5 but I've had two BMW 740 ils well enough to know these things need proper maintenance and the error codes go into a long laundry list of what 'reported fixes' were.

What I want to know is if there is any 'certain' reason for this issue? I'm not sure if it is going to be costly or it is just an electrical issue but would like any advice from X5 owners or any other BMW owners that has had this issue and or fixed?

Thank you in advance!

http://treycreativeservices.com/images/x5-300x225.jpg

x5alpine 09-25-2013 06:07 PM

For me it was the mas air flow sensor on my 02 4.6is. I went to pass someone on the highway and all the lights as well as the "engine fail safe" came on. Its usually just an electrical issue.

TreySamuels 10-11-2013 08:23 PM

Thanks x5alpine. After searching around online it seemed the consensus is the MAF. I tried to do it the inexpensive way by cleaning it with the MAF Sensor cleaner. It cleared the "Engine Failsafe light" and I even experienced what felt like more horsepower in the vehicle.

But about a week later, it started with a new symptom of sputtering, check engine lights back on and now idles rough. I got the codes read and there were more error codes presented now. Here they are:

p0300, p0175, p1350, p1342, p1347, p1344, p1346, p1083, p1085, p1500, p0172

I just ordered a remanufactured Cardone MAF so it will be here in the morning. Hope this solves this 'major' issue as I need just another month of pushing it to work and then I can baby the X5 with the pieces it needs....New job!

Will post my findings once I replace the old with the new...:dunno:

QSilver7 10-12-2013 07:00 AM

Quote:

about a week later, it started with a new symptom of sputtering, check engine lights back on and now idles rough. I got the codes read and there were more error codes presented now. Here they are:

p0300, p0175, p1350, p1342, p1347, p1344, p1346, p1083, p1085, p1500, p0172
Just curious...when I look up info about all the OBD fault codes you listed...I see a lot of things that would suggest checking certain areas first that don't necessarily require spending money for parts just yet.

I see lots of issues with miss-fires in specific cylinders & vacuum leaks. Since an internal combustion engine requires spark, fuel, and air...some deduction/investigation as to why these miss-fires are occurring should be looked at...which should then point you in the direction of the likely culprit(s).

If you've already checked out the info at the links below (found by typing the DTC code in a google search box)...then never mind. :) I only posted it because you didn't give any indication that you've already researched the codes to see what may have caused them...then dismissed any that don't apply.

cshrussell 10-13-2013 11:06 AM

2003 BMW X5 E53 "Engine Failsafe Prog" Error Light***
 
Mine said that And even would shut down while driving like I threw it from fifth gear to second. Scared me to death! After revisiting the mechanic five times because it was never certain what was wrong, it ended up being my alternator being replaced.


Sent from BimmerApp mobile app

TreySamuels 10-22-2013 09:49 AM

2003 BMW X5 E53 "Engine Failsafe Prog" Error Light***
 
Replaced the MAF sensor and it rode sweet for about 5 days. No more "Engine Failsafe" light but the SES light came back on after the car was reset.

Now, only in the mornings the car seems to be idling rough and I need to warm this thing up for 30-45 minutes before it stops. It feels like it would die off.

I read on another post that the MAF might be faulty, but it could be the oxygen sensors, the fuel filter, some hoses and so much more...

I will be taking this to the mechanic this weekend to see what he says.

All the codes I've posted is still showing up.

p0300, p0175, p1350, p1342, p1347, p1344, p1346, p1083, p1085, p1500, p0172

Is anyone familiar with this issue and any suggestions of what could it be?
I am sure it is not one thing here as the SUV is 10 years old now.

Any responses would be greatly appreciated. Thank you!

2003 BMW X5
3.0i
122,000 Miles

dsteins 10-26-2013 05:21 PM

My wife has a 2006 X5 with just over 100K miles on it. She received the following annunicator on her car "check engine failsafe program. Fault in engine electronics. You can continue to drive with reduced engine output or engine speed. Please have the system inspected by your BMW center." Anyone had any experience with this annunicator what the cost was to have it resolved. Had a 1998 528i where I struggled with a 'check engine light' for 5 years before I finally got it fixed. Hope the 'fixes' are similar. Any help/input would be appreciated.

QSilver7 10-26-2013 08:02 PM

Quote:

Originally Posted by dsteins (Post 7920306)
My wife has a 2006 X5 with just over 100K miles on it. She received the following annunicator on her car "check engine failsafe program. Fault in engine electronics. You can continue to drive with reduced engine output or engine speed. Please have the system inspected by your BMW center." Anyone had any experience with this annunicator what the cost was to have it resolved. Had a 1998 528i where I struggled with a 'check engine light' for 5 years before I finally got it fixed. Hope the 'fixes' are similar. Any help/input would be appreciated.

Just on a lark...have you checked the health of X's battery? I ask because it is approx 7 years old (normal life cycle of the original battery)...and that warning is notorious for showing up when battery voltage drops below 11.89 volts (and battery is on it's last leg).

Just a thought...especially if there doesn't appear to be any other issues or symptoms of engine failure. Are you having an other odd electrical glitches that may be indicating the battery as a possible culprit? Do OBC TEST 9 with the ignition in position 1 to see what the battery's voltage is...or if you have a multi-meter...you can use that.

Rcooper 06-13-2014 11:47 PM

is that at any time, running or no ?


All times are GMT -7. The time now is 05:34 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms