Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 191
Search took 0.94 seconds.
Search: Keyword(s): ; Posts Made By: ncord
Forum: X3 E83 (2004 - 2010) 04-09-2015, 02:38 AM
Replies: 587
Views: 67,353
Posted By ncord
06 X3 106,000 Mi.Running strong.

06 X3 106,000 Mi.Running strong.
Forum: X3 E83 (2004 - 2010) 03-07-2015, 03:20 AM
Replies: 6
Views: 460
Posted By ncord
I purchased mine at Walmart 3 yrs. ago and have...

I purchased mine at Walmart 3 yrs. ago and have had no problems.
Everstart #H9 I believe Approx $110.
He is feeding you a line of BS
Forum: X3 E83 (2004 - 2010) 02-24-2015, 04:22 AM
Replies: 62
Views: 7,779
Posted By ncord
Just purchased these thru Amazon ent Details ...

Just purchased these thru Amazon
ent Details


2x Lesjofors 4208450 Coil Spring
Sold by BMA Parts - Since 1978
Condition: New

Facebook Twitter Pinterest $166.10
Forum: X3 E83 (2004 - 2010) 02-24-2015, 03:44 AM
Replies: 17
Views: 621
Posted By ncord
You may need a new battery.This happened to me 3...

You may need a new battery.This happened to me 3 yrs ago .The car went into limp mode ,all the lites came on.I picked up a battery at Walmart and all has been good since. $110.
Forum: X3 E83 (2004 - 2010) 02-13-2015, 03:01 AM
Replies: 13
Views: 558
Posted By ncord
I got mine at Walmart. Exact fit and about $110. ...

I got mine at Walmart. Exact fit and about $110.
Hadit for 3 yrs.with no problem
Forum: X3 E83 (2004 - 2010) 01-14-2015, 01:48 AM
Replies: 6
Views: 428
Posted By ncord
I have Mich.MXV4.Over 40k miles and still looking...

I have Mich.MXV4.Over 40k miles and still looking and handling great.
Forum: X3 E83 (2004 - 2010) 01-03-2015, 01:46 AM
Replies: 31
Views: 961
Posted By ncord
Made it to Florida Dec 30 with zero problems. ...

Made it to Florida Dec 30 with zero problems.
Thanks again for all the help
Forum: X3 E83 (2004 - 2010) 12-26-2014, 02:49 AM
Replies: 31
Views: 961
Posted By ncord
Thanks for your good wishes.Travelled about 75...

Thanks for your good wishes.Travelled about 75 miles yesterday at hwy.and city speeds,
and everything worked great. Here`s hoping
Forum: X3 E83 (2004 - 2010) 12-24-2014, 03:16 PM
Replies: 31
Views: 961
Posted By ncord
Well,everything is back together and working...

Well,everything is back together and working perfect.the leak was coming from one of the top hose connections (small one).Thought I heard them both clic into place but was wrong.
Yes the tank was...
Forum: X3 E83 (2004 - 2010) 12-24-2014, 01:29 AM
Replies: 31
Views: 961
Posted By ncord
Already have the rental fro day on,but the...

Already have the rental fro day on,but the charges are adding up
Forum: X3 E83 (2004 - 2010) 12-24-2014, 01:26 AM
Replies: 31
Views: 961
Posted By ncord
The hair dryer worked,thanks. Everything is...

The hair dryer worked,thanks.
Everything is back together but after refilling and bleeding air out ,I still
have a leak.will have to go at it in the AM and try and find it.
Also the heater goes...
Forum: X3 E83 (2004 - 2010) 12-23-2014, 11:35 AM
Replies: 31
Views: 961
Posted By ncord
Got the parts ,and the old one is out.Just cant...

Got the parts ,and the old one is out.Just cant get the broken tran.thermo out.
O- rings won`t budge
Forum: X3 E83 (2004 - 2010) 12-23-2014, 11:32 AM
Replies: 31
Views: 961
Posted By ncord
As expected the trans .cooler thermostat came out...

As expected the trans .cooler thermostat came out in pieces.I have the new one but cant get the bottom half of the old one out.
Tried prying with screw driver and needlenose but wont budge.Any tips...
Forum: X3 E83 (2004 - 2010) 12-22-2014, 01:17 AM
Replies: 31
Views: 961
Posted By ncord
leaking collant

Iheard a slight pop when engine was idling.next the coolant light cam on
intermitantly.drove to get some coolant and rad was emty by time i stopped.Coolant on ground mostly under reservoir...
Forum: X3 E83 (2004 - 2010) 11-05-2014, 06:17 PM
Replies: 6
Views: 466
Posted By ncord
Let me know how it works out for you.

Let me know how it works out for you.
Forum: X3 E83 (2004 - 2010) 11-04-2014, 11:07 AM
Replies: 6
Views: 466
Posted By ncord
06 X3 3.0i

Still have the misfire under load at 3000 rpm.Anyone come up with a solution that works yet?
Forum: X3 E83 (2004 - 2010) 10-25-2014, 03:43 AM
Replies: 4
Views: 530
Posted By ncord
If its a Canadian car it might be your DRL`s....

If its a Canadian car it might be your DRL`s. (Daytime running lites )
Forum: X3 E83 (2004 - 2010) 09-24-2014, 01:56 PM
Replies: 5
Views: 376
Posted By ncord
Mine was on the end of the box facing the front...

Mine was on the end of the box facing the front .You might want to check there
Forum: X3 E83 (2004 - 2010) 09-22-2014, 01:43 PM
Replies: 54
Views: 7,066
Posted By ncord
Sounds great....Let us know in a few weeks if it...

Sounds great....Let us know in a few weeks if it lasts.
Some people have had good luck but it returns down the road.
Here`s hoping yours is a permanent fix
Forum: X3 E83 (2004 - 2010) 09-10-2014, 02:14 PM
Replies: 27
Views: 18,057
Posted By ncord
I just did mine and had the same results .65...

I just did mine and had the same results .65 litres came out and .9 went in.
I didn`t have the car quite level,so that might have been why it took more.
Was wondering if too much fluid can damage...
Forum: X3 E83 (2004 - 2010) 09-05-2014, 01:08 PM
Replies: 54
Views: 7,066
Posted By ncord
How you making out with the misfire problem

How you making out with the misfire problem
Forum: X3 E83 (2004 - 2010) 08-25-2014, 04:02 AM
Replies: 54
Views: 7,066
Posted By ncord
How did you make out with your misfire problem.I...

How did you make out with your misfire problem.I stlii have mine after doing almost every
thing listed before
Forum: X3 E83 (2004 - 2010) 08-10-2014, 03:21 AM
Replies: 6
Views: 786
Posted By ncord
How old is your battery? A bad one could cause...

How old is your battery? A bad one could cause the lights to come on and the car to run
in safe mode.
Forum: X3 E83 (2004 - 2010) 08-03-2014, 01:24 PM
Replies: 7
Views: 541
Posted By ncord
100,K miles

Just past 100k in my 06 ...So far have replaced VCG,plugs,coil pacs,oxygen sensors,front struts,brakes,and air intake boot.Battery and tires as well a couple of years ago.
Truck runs great except...
Forum: X3 E83 (2004 - 2010) 07-28-2014, 02:08 PM
Replies: 5
Views: 552
Posted By ncord
Why not try a "reputable" transmission specialist...

Why not try a "reputable" transmission specialist if you can find one .
The BMW dealers are bandits
Showing results 1 to 25 of 191

Forum Jump

All times are GMT -7. The time now is 03:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms