Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 2 of 2
Search took 0.27 seconds.
Search: Keyword(s): ; Posts Made By: Scooter S
Forum: X3 E83 (2004 - 2010) 12-30-2011, 07:24 PM
Replies: 17
Views: 14,657
Posted By Scooter S
I have an '05 X3 with 100,000 miles and also just...

I have an '05 X3 with 100,000 miles and also just had a code p0171 fixed this week. The car seemed to be running okay (normal acceleration and mpg), but did have a vacuum leak. The repair shop...
Forum: X3 E83 (2004 - 2010) 12-30-2011, 07:03 PM
Replies: 42
Views: 5,538
Posted By Scooter S
I have had two sets of Pirellis which have gotten...

I have had two sets of Pirellis which have gotten me to 100,000 miles on my '05 X3. I've kept them rotated, aligned, and inflated regularly and had no problems or complaints. Looking at Michelin...
Showing results 1 to 2 of 2

Forum Jump

All times are GMT -7. The time now is 01:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms