Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 198
Search took 0.53 seconds.
Search: Keyword(s): ; Posts Made By: ncord
Forum: X3 E83 (2004 - 2010) Yesterday, 03:42 PM
Replies: 7
Views: 363
Posted By ncord
I see how the plate is removed, but how do you...

I see how the plate is removed, but how do you disconnect the cable? I can`t see where it is connected.
Forum: X3 E83 (2004 - 2010) 08-26-2015, 03:42 AM
Replies: 7
Views: 363
Posted By ncord
I have a similar issue.But in my case the drive...

I have a similar issue.But in my case the drive cable plate is broken and I can`t see
how it comes out as it is permanently attached to the cable.I have the repair kit but can`t figure out how to...
Forum: X3 E83 (2004 - 2010) 08-07-2015, 03:39 AM
Replies: 27
Views: 892
Posted By ncord
Please let us know what the dealer comes up...

Please let us know what the dealer comes up with.I have replaced all that has been mentioned and more but still have the misfire under load.
Forum: X3 E83 (2004 - 2010) 08-01-2015, 03:10 AM
Replies: 11
Views: 557
Posted By ncord
If not already done ,you should change the...

If not already done ,you should change the expansion bottle on the rad
and the transfer case fluid.
Forum: X3 E83 (2004 - 2010) 06-25-2015, 03:34 AM
Replies: 5
Views: 348
Posted By ncord
You could try disconnecting the unit at the back...

You could try disconnecting the unit at the back and then re-connect.
Worked for me when I first got my 06 X3.Be carefull with the plug,it is a little tricky
Forum: X3 E83 (2004 - 2010) 05-08-2015, 04:05 AM
Replies: 9
Views: 742
Posted By ncord
Just curious but what year is your X3.I don`t...

Just curious but what year is your X3.I don`t have a interior button for my tailgate on my 06
Forum: X3 E83 (2004 - 2010) 05-08-2015, 03:43 AM
Replies: 10
Views: 580
Posted By ncord
I have the same problem since drilled rotors were...

I have the same problem since drilled rotors were installed.Let me know if you find a cure.
Forum: X3 E83 (2004 - 2010) 04-09-2015, 02:38 AM
Replies: 606
Views: 71,792
Posted By ncord
06 X3 106,000 Mi.Running strong.

06 X3 106,000 Mi.Running strong.
Forum: X3 E83 (2004 - 2010) 03-07-2015, 03:20 AM
Replies: 6
Views: 627
Posted By ncord
I purchased mine at Walmart 3 yrs. ago and have...

I purchased mine at Walmart 3 yrs. ago and have had no problems.
Everstart #H9 I believe Approx $110.
He is feeding you a line of BS
Forum: X3 E83 (2004 - 2010) 02-24-2015, 04:22 AM
Replies: 82
Views: 10,769
Posted By ncord
Just purchased these thru Amazon ent Details ...

Just purchased these thru Amazon
ent Details


2x Lesjofors 4208450 Coil Spring
Sold by BMA Parts - Since 1978
Condition: New

Facebook Twitter Pinterest $166.10
Forum: X3 E83 (2004 - 2010) 02-24-2015, 03:44 AM
Replies: 17
Views: 937
Posted By ncord
You may need a new battery.This happened to me 3...

You may need a new battery.This happened to me 3 yrs ago .The car went into limp mode ,all the lites came on.I picked up a battery at Walmart and all has been good since. $110.
Forum: X3 E83 (2004 - 2010) 02-13-2015, 03:01 AM
Replies: 21
Views: 1,160
Posted By ncord
I got mine at Walmart. Exact fit and about $110. ...

I got mine at Walmart. Exact fit and about $110.
Hadit for 3 yrs.with no problem
Forum: X3 E83 (2004 - 2010) 01-14-2015, 01:48 AM
Replies: 7
Views: 636
Posted By ncord
I have Mich.MXV4.Over 40k miles and still looking...

I have Mich.MXV4.Over 40k miles and still looking and handling great.
Forum: X3 E83 (2004 - 2010) 01-03-2015, 01:46 AM
Replies: 31
Views: 1,125
Posted By ncord
Made it to Florida Dec 30 with zero problems. ...

Made it to Florida Dec 30 with zero problems.
Thanks again for all the help
Forum: X3 E83 (2004 - 2010) 12-26-2014, 02:49 AM
Replies: 31
Views: 1,125
Posted By ncord
Thanks for your good wishes.Travelled about 75...

Thanks for your good wishes.Travelled about 75 miles yesterday at hwy.and city speeds,
and everything worked great. Here`s hoping
Forum: X3 E83 (2004 - 2010) 12-24-2014, 03:16 PM
Replies: 31
Views: 1,125
Posted By ncord
Well,everything is back together and working...

Well,everything is back together and working perfect.the leak was coming from one of the top hose connections (small one).Thought I heard them both clic into place but was wrong.
Yes the tank was...
Forum: X3 E83 (2004 - 2010) 12-24-2014, 01:29 AM
Replies: 31
Views: 1,125
Posted By ncord
Already have the rental fro day on,but the...

Already have the rental fro day on,but the charges are adding up
Forum: X3 E83 (2004 - 2010) 12-24-2014, 01:26 AM
Replies: 31
Views: 1,125
Posted By ncord
The hair dryer worked,thanks. Everything is...

The hair dryer worked,thanks.
Everything is back together but after refilling and bleeding air out ,I still
have a leak.will have to go at it in the AM and try and find it.
Also the heater goes...
Forum: X3 E83 (2004 - 2010) 12-23-2014, 11:35 AM
Replies: 31
Views: 1,125
Posted By ncord
Got the parts ,and the old one is out.Just cant...

Got the parts ,and the old one is out.Just cant get the broken tran.thermo out.
O- rings won`t budge
Forum: X3 E83 (2004 - 2010) 12-23-2014, 11:32 AM
Replies: 31
Views: 1,125
Posted By ncord
As expected the trans .cooler thermostat came out...

As expected the trans .cooler thermostat came out in pieces.I have the new one but cant get the bottom half of the old one out.
Tried prying with screw driver and needlenose but wont budge.Any tips...
Forum: X3 E83 (2004 - 2010) 12-22-2014, 01:17 AM
Replies: 31
Views: 1,125
Posted By ncord
leaking collant

Iheard a slight pop when engine was idling.next the coolant light cam on
intermitantly.drove to get some coolant and rad was emty by time i stopped.Coolant on ground mostly under reservoir...
Forum: X3 E83 (2004 - 2010) 11-05-2014, 06:17 PM
Replies: 6
Views: 527
Posted By ncord
Let me know how it works out for you.

Let me know how it works out for you.
Forum: X3 E83 (2004 - 2010) 11-04-2014, 11:07 AM
Replies: 6
Views: 527
Posted By ncord
06 X3 3.0i

Still have the misfire under load at 3000 rpm.Anyone come up with a solution that works yet?
Forum: X3 E83 (2004 - 2010) 10-25-2014, 03:43 AM
Replies: 4
Views: 685
Posted By ncord
If its a Canadian car it might be your DRL`s....

If its a Canadian car it might be your DRL`s. (Daytime running lites )
Forum: X3 E83 (2004 - 2010) 09-24-2014, 01:56 PM
Replies: 5
Views: 417
Posted By ncord
Mine was on the end of the box facing the front...

Mine was on the end of the box facing the front .You might want to check there
Showing results 1 to 25 of 198

Forum Jump

All times are GMT -7. The time now is 08:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms