Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 207
Search took 0.52 seconds.
Search: Keyword(s): ; Posts Made By: ncord
Forum: X3 E83 (2004 - 2010) 02-06-2016, 04:49 AM
Replies: 7
Views: 369
Posted By ncord
Got my filter kit from Eeuroparts Qty: 1 - Item...

Got my filter kit from Eeuroparts Qty: 1 - Item #: 24117557070 - Desc: Auto Trans Filter Kit - Unit Price: $25.99.
I used the Castrol Dexron VI .Just drove from Canada to Florida,and ran great.
Forum: X3 E83 (2004 - 2010) 01-13-2016, 05:27 AM
Replies: 79
Views: 22,245
Posted By ncord
I used the Lesjofor rear springs and Monroe...

I used the Lesjofor rear springs and Monroe spectrum rear shocks.
Approx. $350. complete with new mounting pads.All from Amazon.
Very happy with ride.
Forum: X3 E83 (2004 - 2010) 01-03-2016, 05:12 AM
Replies: 12
Views: 2,265
Posted By ncord
I replaced my front struts at 100k miles,one was...

I replaced my front struts at 100k miles,one was leaking.
I did the rear shocks and springs at 110k mi. Both springs were broke
and the shocks were leaking
Forum: X3 E83 (2004 - 2010) 01-02-2016, 04:20 AM
Replies: 4
Views: 412
Posted By ncord
Sun Roof Repair

I have the same problem as you,and have purchased the repair kit as well.
I would greatly appreciate any DIY photos or videos you can supply to help me with my repair.I have had the glass...
Forum: X3 E83 (2004 - 2010) 12-06-2015, 03:56 AM
Replies: 20
Views: 7,376
Posted By ncord
I have the Michelin Primacy MXV4 on my 06 X3 Have...

I have the Michelin Primacy MXV4 on my 06 X3 Have 50k miles on them and still look and feel almost new.
I have also used this tire on my Camry in the past with great results.
Forum: X3 E83 (2004 - 2010) 11-06-2015, 08:53 AM
Replies: 70
Views: 21,972
Posted By ncord
Mine is the same ,.Under load going uphill and...

Mine is the same ,.Under load going uphill and when Im towing my boat uphill.
Forum: X3 E83 (2004 - 2010) 11-06-2015, 05:14 AM
Replies: 11
Views: 547
Posted By ncord
I would replace the expansion tank asap...Mine...

I would replace the expansion tank asap...Mine blew around 100K miles with no warning.
And of course I was a hundred miles from home at Christmas time.Ended up costing
a fortune for parts as I was...
Forum: X3 E83 (2004 - 2010) 11-05-2015, 03:54 AM
Replies: 70
Views: 21,972
Posted By ncord
I have the same problem.The only thing I havn`t...

I have the same problem.The only thing I havn`t replaced is the ccv valve but it seems ok.
No milky stuff under oil cap and it idles good. I`m thinking a vacuum line but havn`t found it yet. Let me...
Forum: X3 E83 (2004 - 2010) 09-13-2015, 04:37 AM
Replies: 9
Views: 776
Posted By ncord
Can somebody please tell me how the cable plate...

Can somebody please tell me how the cable plate and cable are removed?
Do I have to remove the motor?The cable is so long,I can`t see where it all goes.
Forum: X3 E83 (2004 - 2010) 08-27-2015, 04:42 PM
Replies: 9
Views: 776
Posted By ncord
I see how the plate is removed, but how do you...

I see how the plate is removed, but how do you disconnect the cable? I can`t see where it is connected.
Forum: X3 E83 (2004 - 2010) 08-26-2015, 04:42 AM
Replies: 9
Views: 776
Posted By ncord
I have a similar issue.But in my case the drive...

I have a similar issue.But in my case the drive cable plate is broken and I can`t see
how it comes out as it is permanently attached to the cable.I have the repair kit but can`t figure out how to...
Forum: X3 E83 (2004 - 2010) 08-07-2015, 04:39 AM
Replies: 27
Views: 1,252
Posted By ncord
Please let us know what the dealer comes up...

Please let us know what the dealer comes up with.I have replaced all that has been mentioned and more but still have the misfire under load.
Forum: X3 E83 (2004 - 2010) 08-01-2015, 04:10 AM
Replies: 11
Views: 695
Posted By ncord
If not already done ,you should change the...

If not already done ,you should change the expansion bottle on the rad
and the transfer case fluid.
Forum: X3 E83 (2004 - 2010) 06-25-2015, 04:34 AM
Replies: 5
Views: 422
Posted By ncord
You could try disconnecting the unit at the back...

You could try disconnecting the unit at the back and then re-connect.
Worked for me when I first got my 06 X3.Be carefull with the plug,it is a little tricky
Forum: X3 E83 (2004 - 2010) 05-08-2015, 05:05 AM
Replies: 9
Views: 848
Posted By ncord
Just curious but what year is your X3.I don`t...

Just curious but what year is your X3.I don`t have a interior button for my tailgate on my 06
Forum: X3 E83 (2004 - 2010) 05-08-2015, 04:43 AM
Replies: 10
Views: 664
Posted By ncord
I have the same problem since drilled rotors were...

I have the same problem since drilled rotors were installed.Let me know if you find a cure.
Forum: X3 E83 (2004 - 2010) 04-09-2015, 03:38 AM
Replies: 637
Views: 76,422
Posted By ncord
06 X3 106,000 Mi.Running strong.

06 X3 106,000 Mi.Running strong.
Forum: X3 E83 (2004 - 2010) 03-07-2015, 04:20 AM
Replies: 6
Views: 837
Posted By ncord
I purchased mine at Walmart 3 yrs. ago and have...

I purchased mine at Walmart 3 yrs. ago and have had no problems.
Everstart #H9 I believe Approx $110.
He is feeding you a line of BS
Forum: X3 E83 (2004 - 2010) 02-24-2015, 05:22 AM
Replies: 82
Views: 12,701
Posted By ncord
Just purchased these thru Amazon ent Details ...

Just purchased these thru Amazon
ent Details


2x Lesjofors 4208450 Coil Spring
Sold by BMA Parts - Since 1978
Condition: New

Facebook Twitter Pinterest $166.10
Forum: X3 E83 (2004 - 2010) 02-24-2015, 04:44 AM
Replies: 24
Views: 1,814
Posted By ncord
You may need a new battery.This happened to me 3...

You may need a new battery.This happened to me 3 yrs ago .The car went into limp mode ,all the lites came on.I picked up a battery at Walmart and all has been good since. $110.
Forum: X3 E83 (2004 - 2010) 02-13-2015, 04:01 AM
Replies: 21
Views: 1,587
Posted By ncord
I got mine at Walmart. Exact fit and about $110. ...

I got mine at Walmart. Exact fit and about $110.
Hadit for 3 yrs.with no problem
Forum: X3 E83 (2004 - 2010) 01-14-2015, 02:48 AM
Replies: 7
Views: 752
Posted By ncord
I have Mich.MXV4.Over 40k miles and still looking...

I have Mich.MXV4.Over 40k miles and still looking and handling great.
Forum: X3 E83 (2004 - 2010) 01-03-2015, 02:46 AM
Replies: 31
Views: 1,284
Posted By ncord
Made it to Florida Dec 30 with zero problems. ...

Made it to Florida Dec 30 with zero problems.
Thanks again for all the help
Forum: X3 E83 (2004 - 2010) 12-26-2014, 03:49 AM
Replies: 31
Views: 1,284
Posted By ncord
Thanks for your good wishes.Travelled about 75...

Thanks for your good wishes.Travelled about 75 miles yesterday at hwy.and city speeds,
and everything worked great. Here`s hoping
Forum: X3 E83 (2004 - 2010) 12-24-2014, 04:16 PM
Replies: 31
Views: 1,284
Posted By ncord
Well,everything is back together and working...

Well,everything is back together and working perfect.the leak was coming from one of the top hose connections (small one).Thought I heard them both clic into place but was wrong.
Yes the tank was...
Showing results 1 to 25 of 207

Forum Jump

All times are GMT -7. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms