Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 6 of 6
Search took 0.76 seconds.
Search: Keyword(s): ; Posts Made By: Clevelandesign
Forum: 5 Series DIY 03-28-2009, 10:33 PM
Replies: 54
Views: 45,838
Posted By Clevelandesign
Thank you! for the instruction and for first...

Thank you! for the instruction and for first trying it yourself. So, I guess that 2maro I will get motivated and purchase these products.
Forum: E46 (1999 - 2006) 09-05-2008, 10:56 PM
Replies: 4
Views: 748
Posted By Clevelandesign
Thanks Bob...

Thanks Bob...
Forum: E46 (1999 - 2006) 09-04-2008, 11:57 PM
Replies: 4
Views: 748
Posted By Clevelandesign
Engine Stalls

My car does the same thing. Did you ever get an anwser to the problem? I have heard the it is the oxygen sensors, others have said its the fuel pressure regulator. I have not had it fixed yet. I did...
Forum: E39 (1997 - 2003) 08-27-2008, 10:48 PM
Replies: 0
Views: 454
Posted By Clevelandesign
Engine sometimes shuts off on acceleration

Does anyone or has anyone had problems with your car shutting off on acceleration? The car starts right up again, but stalls from time to time when pulling off from a stop. Is this an Oxygen Sensor...
Forum: E39 (1997 - 2003) 08-27-2008, 10:42 PM
Replies: 0
Views: 340
Posted By Clevelandesign
Cool Clevelandesign

Hello, I have a 2002 530i, when pulling of from a stop the engine sometimes dies on me. No problem starting it after. It doesn't happen often, but when it does it is very annoying.

Any ideas as to...
Forum: E39 (1997 - 2003) 07-13-2008, 12:30 AM
Replies: 3
Views: 597
Posted By Clevelandesign
Intrument Cluster

I have a 2002 530i, once i signed into the forum in January and another member made reference to contacting BMW USA to fix the pixel problem. I did about a month ago and BMW USA paid for the pixel...
Showing results 1 to 6 of 6

Forum Jump

All times are GMT -7. The time now is 04:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms