Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 22 of 22
Search took 0.20 seconds.
Search: Keyword(s): ; Posts Made By: raider03
Forum: X5 E53 (1999 - 2006) 04-17-2013, 11:10 AM
Replies: 16
Views: 698
Posted By raider03
Also could be that you have a bad MAF sensor....

Also could be that you have a bad MAF sensor. Unplug it and see if the car runs better with it unplugged if so then the MAF needs to be replaced. Another known issue, is that the DISA valve fails to...
Forum: X5 E53 (1999 - 2006) 04-15-2013, 05:43 PM
Replies: 16
Views: 698
Posted By raider03
Any OBDII codes? could be about anything. It will...

Any OBDII codes? could be about anything. It will help if u can get the codes of the ECU
Forum: X5 E53 (1999 - 2006) 04-13-2013, 12:41 AM
Replies: 8
Views: 942
Posted By raider03
Could be an air leak causing your shaking or fuel...

Could be an air leak causing your shaking or fuel delivery problem. CHeck for air leaks and check fuel pressure.
Forum: X5 E53 (1999 - 2006) 04-13-2013, 12:39 AM
Replies: 4
Views: 475
Posted By raider03
Check battery and possibly fuses...

Check battery and possibly fuses...
Forum: X5 E53 (1999 - 2006) 04-10-2013, 12:19 PM
Replies: 1
Views: 346
Posted By raider03
Post What are your MAF readings?

Hey guys trying to determine if my MAF is on its way out or not. Took some readings at idle and they seem to be between 2.4 to 3.6 grams/sec, seems a bit low to me? I have a 01 BMW X5 3.0.

What...
Forum: X5 E53 (1999 - 2006) 04-08-2013, 04:04 PM
Replies: 3
Views: 1,021
Posted By raider03
Either the O2 in bank 2 is bad, or you have an...

Either the O2 in bank 2 is bad, or you have an air leak somewhere in bank 2.
Forum: X5 E53 (1999 - 2006) 04-08-2013, 02:55 PM
Replies: 16
Views: 574
Posted By raider03
Ok so I am work and don't have my mirror tool,...

Ok so I am work and don't have my mirror tool, but basically it goes to the back/underside of the intake manifold. Your gonna need a mirror to look behind the intake manifold thats where its going on...
Forum: X5 E53 (1999 - 2006) 04-08-2013, 01:53 PM
Replies: 16
Views: 574
Posted By raider03
A closer pic of it, closer to that area on the...

A closer pic of it, closer to that area on the back would help... and I'll take a look on my X5 to see where it goes.
Forum: X5 E53 (1999 - 2006) 04-08-2013, 12:16 PM
Replies: 16
Views: 574
Posted By raider03
Anyway we can get some closer pic shots of that...

Anyway we can get some closer pic shots of that connector?
Forum: X5 E53 (1999 - 2006) 04-08-2013, 10:56 AM
Replies: 16
Views: 574
Posted By raider03
BTW turn the page for the post cat O2 sensors.

BTW turn the page for the post cat O2 sensors.
Forum: X5 E53 (1999 - 2006) 04-08-2013, 10:55 AM
Replies: 16
Views: 574
Posted By raider03
Maybe you switched the O2 connections? LOL you...

Maybe you switched the O2 connections? LOL you can take a look here http://content.yudu.com/Library/A1pyv7/BMWE395seriesService/resources/531.htm the Post cat O2's connect at the fuel rail. Hope you...
Forum: X5 E53 (1999 - 2006) 04-08-2013, 10:37 AM
Replies: 16
Views: 574
Posted By raider03
That is the post cat O2 sensor connector if I am...

That is the post cat O2 sensor connector if I am not mistaken and it does need to be connected otherwise SEL will turn on.
Forum: X5 E53 (1999 - 2006) 04-08-2013, 10:23 AM
Replies: 8
Views: 795
Posted By raider03
Like Qsilver7 suggested need more specifics and...

Like Qsilver7 suggested need more specifics and details like the milage on your car... but sounds like a fuel delivery problem... Fuel filter, fuel pump, injectors.
Forum: X5 E53 (1999 - 2006) 04-07-2013, 01:33 PM
Replies: 2
Views: 264
Posted By raider03
That is supposed to be like that, it's just a...

That is supposed to be like that, it's just a breather line... I believe it comes from the back of the intake manifold.
Forum: X5 E53 (1999 - 2006) 04-06-2013, 11:17 PM
Replies: 7
Views: 948
Posted By raider03
Sounds like your burning oil... or maybe the most...

Sounds like your burning oil... or maybe the most common cause is the CCV? You should check yours...
Forum: X5 E53 (1999 - 2006) 04-06-2013, 11:28 AM
Replies: 16
Views: 1,929
Posted By raider03
@upallnight thanks for the help. DISA is working...

@upallnight thanks for the help. DISA is working properly.

Had a smoke test done, and seems my Valve cover has a crack in it -___- great. $300 part. LOL I'll have the dealer pay for that...
Forum: X5 E53 (1999 - 2006) 04-03-2013, 11:16 AM
Replies: 16
Views: 1,929
Posted By raider03
Yeah that was one of the first things on my check...

Yeah that was one of the first things on my check list. The O-ring was pretty worn so I made a new gasket with Ultra Copper but didn't make any diff.

One thing I noticed when I took the DISA out,...
Forum: X5 E53 (1999 - 2006) 04-02-2013, 05:12 PM
Replies: 16
Views: 1,929
Posted By raider03
Thanks Buster1015 for the help... Today once...

Thanks Buster1015 for the help...

Today once again bank 2 is lean. Before I order new O2 sensors, I will try to smoke the intake system to make sure I didn't miss any leak. Going to have to create...
Forum: X5 E53 (1999 - 2006) 04-01-2013, 05:53 PM
Replies: 16
Views: 1,929
Posted By raider03
@buster1015 Thanks for helping out &...

@buster1015 Thanks for helping out & understanding I really appreciate it. Really want to get to the bottom of this as I am going thru gas tanks super fast due to the high fuel trims.

Also where...
Forum: X5 E53 (1999 - 2006) 04-01-2013, 03:11 PM
Replies: 16
Views: 1,929
Posted By raider03
Lightbulb Ugh I wish my problem would of been as simple as...

Ugh I wish my problem would of been as simple as that... Unfortunately I checked all my vacuum hoses and all seem fine.

Hopefully someone in here could do a quick check for me and have there MAF...
Forum: X5 E53 (1999 - 2006) 04-01-2013, 01:27 PM
Replies: 16
Views: 1,929
Posted By raider03
Buster1015, couple of questions. I really...

Buster1015, couple of questions.

I really want to replace O2 sensors but at the same time be sure that I have found the culprit as parts are expensive. Just one thing though on Sat the code switch...
Forum: X5 E53 (1999 - 2006) 03-29-2013, 02:03 PM
Replies: 16
Views: 1,929
Posted By raider03
Lightbulb 2001 BMW X5 3.0i running lean!

Hello everyone new to the forum... Few weeks ago bought a 2001 BMW X5 3.0i w/ 108K miles on it. Love the car, but it started throwing P0171 & P0174 codes and they are giving me quite a headache....
Showing results 1 to 22 of 22

Forum Jump

All times are GMT -7. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms