Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 8 of 8
Search took 0.16 seconds.
Search: Keyword(s): ; Posts Made By: fadisarkis
Forum: X5 E53 (1999 - 2006) 11-13-2013, 09:45 AM
Replies: 0
Views: 295
Posted By fadisarkis
4x4 light

I have x5 2004 3.0 sport package
the4x4 light sometimes light on but after I stop the engine and restart the car it goes off for many days and it get on suddenly than the same get off after
what...
Forum: X5 E53 (1999 - 2006) 10-15-2013, 01:53 AM
Replies: 1
Views: 279
Posted By fadisarkis
o2 sensor

hi
I have this error code on scanner - Timing Oxygen sensor bank1 before cat
what should I do

thx
Forum: X5 E53 (1999 - 2006) 06-11-2013, 08:52 PM
Replies: 8
Views: 564
Posted By fadisarkis
I have the automatic climate control

I have the automatic climate control
Forum: X5 E53 (1999 - 2006) 06-11-2013, 09:50 AM
Replies: 8
Views: 564
Posted By fadisarkis
It is runing but the compressor took 4 to 5 min...

It is runing but the compressor took 4 to 5 min before blowing cold air
Forum: X5 E53 (1999 - 2006) 06-11-2013, 08:34 AM
Replies: 8
Views: 564
Posted By fadisarkis
I changed the fan but ac still taking 4 to 5...

I changed the fan but ac still taking 4 to 5 minutes before begin to cool what is the problen thx
Forum: X5 E53 (1999 - 2006) 05-06-2013, 06:21 AM
Replies: 8
Views: 564
Posted By fadisarkis
i noticed that the electric fan in front of...

i noticed that the electric fan in front of radiator didn't work is it the problem??
Forum: X5 E53 (1999 - 2006) 05-06-2013, 04:05 AM
Replies: 8
Views: 564
Posted By fadisarkis
ac problem

hi
x5 2004 3.0
my ac took more than 5 min after starting to blow cold air
what is this problem any idea

thx
Forum: X5 E53 (1999 - 2006) 04-19-2013, 04:55 AM
Replies: 1
Views: 296
Posted By fadisarkis
rain sensor

hi
rain sensor X5 2004 not working what is the problem ?

regards
Showing results 1 to 8 of 8

Forum Jump

All times are GMT -7. The time now is 10:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms