Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 4 of 4
Search took 0.32 seconds.
Search: Keyword(s): ; Posts Made By: TheWick
Forum: X5 E53 (1999 - 2006) 01-11-2011, 10:59 AM
Replies: 2
Views: 1,193
Posted By TheWick
Thanks HPIA, I have the 3.0 engine. I'm...

Thanks HPIA, I have the 3.0 engine. I'm definitely not going to drive it until I replace the thermostat and water pump this weekend.
Forum: X5 E53 (1999 - 2006) 01-11-2011, 06:09 AM
Replies: 8
Views: 4,391
Posted By TheWick
Yep, my 02 X5 carrier had to be replaced this...

Yep, my 02 X5 carrier had to be replaced this summer also.
Forum: X5 E53 (1999 - 2006) 01-10-2011, 03:57 PM
Replies: 9
Views: 2,436
Posted By TheWick
I have an 02 X5 and this fix worked for me too!

I have an 02 X5 and this fix worked for me too!
Forum: X5 E53 (1999 - 2006) 01-10-2011, 03:45 PM
Replies: 2
Views: 1,193
Posted By TheWick
02 X5 SES light on and Temp Gauge in the red

I've read through several posts but haven't discovered a common fix for this yet.

My 2002 X5 has about 90,000 miles on it and this weekend the Service Engine Soon light came on and I noticed the...
Showing results 1 to 4 of 4

Forum Jump

All times are GMT -7. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms