Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 17 of 17
Search took 0.26 seconds.
Search: Keyword(s): ; Posts Made By: desertviking
Forum: X5 E53 (1999 - 2006) 11-12-2013, 08:50 PM
Replies: 21
Views: 8,587
Posted By desertviking
x5 4.4i v8 smoke problems PLEASE HELP!

You are not going to like this.
Mine did the same exact thing. It was the dreaded valve stem repair. ($3600) at indie garage. As soon as I mentioned it to my mechanic he knew what it was.
I asked...
Forum: X5 E53 (1999 - 2006) 11-12-2013, 08:28 PM
Replies: 4
Views: 422
Posted By desertviking
High beam way too high

Thanks. I will check that out.
My low beams are adjustable and works fine.


Sent from BimmerApp mobile app
Forum: X5 E53 (1999 - 2006) 11-11-2013, 04:33 PM
Replies: 4
Views: 422
Posted By desertviking
Well I bought it when it was 2 years old. No one...

Well I bought it when it was 2 years old. No one have adjusted them while I have had it.
I do have the adaptive xenons..
I'll take a look at the adjustment procedure...
Thanks!
Forum: X5 E53 (1999 - 2006) 11-11-2013, 12:15 PM
Replies: 4
Views: 422
Posted By desertviking
High beam way too high

HI All,
Ever since I have had my car the high beam seem to way too high, low beam ok. I can see it when I am next to trees and mountains that it shines way up onto them while it barely makes a...
Forum: X5 E53 (1999 - 2006) 08-02-2013, 08:04 AM
Replies: 1
Views: 752
Posted By desertviking
2006 X5 4.4 passenger temp too high

Fixed!
Was low on freon!


Sent from BimmerApp mobile app
Forum: X5 E53 (1999 - 2006) 08-01-2013, 03:19 PM
Replies: 5
Views: 510
Posted By desertviking
Valve stem repair

I had about 150k on the engine


Sent from BimmerApp mobile app
Forum: X5 E53 (1999 - 2006) 08-01-2013, 11:09 AM
Replies: 5
Views: 510
Posted By desertviking
Valve stem repair

Now you tell me!! :)
I would think that I ought to be able to trust a built in guide to an expensive car. If following that guide cause undue damage to the car, the guide oughtn't be there.
I am...
Forum: X5 E53 (1999 - 2006) 07-31-2013, 04:11 PM
Replies: 4
Views: 600
Posted By desertviking
2006 whining noise

I had the same issue
Had the pulleys and belts replaced to no avail.
They fixed it by replacing these two identical parts and forgive me I forget the name of them. I think they sit on the...
Forum: X5 E53 (1999 - 2006) 07-31-2013, 04:02 PM
Replies: 5
Views: 510
Posted By desertviking
Valve stem repair

I just had mine done. Cost = $3600!
My mechanic said that it is common!
I always followed those little service indicators, but never had the oil change light come on. Despite never having it come...
Forum: X3 E83 (2004 - 2010) 03-30-2013, 07:07 PM
Replies: 497
Views: 161,173
Posted By desertviking
knock on wood, so far after almost a year, I...

knock on wood, so far after almost a year, I haven't had any problems..
Forum: X5 E53 (1999 - 2006) 01-26-2013, 11:35 PM
Replies: 1
Views: 519
Posted By desertviking
I just did mine. I believe there is a thread here...

I just did mine. I believe there is a thread here that shows you how to.
It takes a little doing.
Forum: X5 E53 (1999 - 2006) 01-26-2013, 06:00 PM
Replies: 5
Views: 1,454
Posted By desertviking
Ok, so I got it working again. I disconnected...

Ok, so I got it working again.
I disconnected the battery for about 30 min, cause I figured that the computer needed to be reset. Now everything is working including the adaptive system. I figure...
Forum: X5 E53 (1999 - 2006) 01-26-2013, 12:15 PM
Replies: 5
Views: 1,454
Posted By desertviking
2006 X5 HID low beam not working

Hi THere,
Hopefully there is someone here that can help me.
I recently installed non-OEM HID bulbs. I went for the 6000's rather than the 4300K.
Worked fine until a week ago the little green light...
Forum: X5 E53 (1999 - 2006) 06-27-2012, 05:23 PM
Replies: 1
Views: 752
Posted By desertviking
2006 X5 4.4 passenger temp too high

Hi Everyone,
It is summer here in Palm Springs and it is 110 today!
My passenger temp is set at 60 degrees, driver is at 73, but the air from passenger vents is probably 10 degrees higher than the...
Forum: X3 E83 (2004 - 2010) 03-28-2012, 04:26 PM
Replies: 497
Views: 161,173
Posted By desertviking
Well.... I am now back to the original issue...

Well....
I am now back to the original issue which is: When I start up the car, I get a squealing sound like a belt slipping. When it began, I would quickly shut off the engine, turn it back on and...
Forum: X3 E83 (2004 - 2010) 03-24-2012, 01:42 PM
Replies: 497
Views: 161,173
Posted By desertviking
Update to repair

In my former post I said that I noticed 3 cracks on the bottom of the white nylon gear.
I decided to take it apart again and reinforce the gear with a sleeve. I found a 1 1/4 inch brass drain pipe...
Forum: X3 E83 (2004 - 2010) 03-23-2012, 12:54 PM
Replies: 497
Views: 161,173
Posted By desertviking
Transfer case actuator motor assembly

:):)
Thank you sooooo much for the post.
I followed the instructions and it is now working.
However like someone posted I am not sure if it will work once 4X4 is asked for, but the 4X4 light went...
Showing results 1 to 17 of 17

Forum Jump

All times are GMT -7. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms