Bimmerfest - BMW Forums - Search Results



Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 34
Search took 0.14 seconds.
Search: Keyword(s): ; Posts Made By: Sebringx
Forum: 7 Series - E65 / E66 (2002 - 2008) 01-31-2013, 06:51 PM
Replies: 12
Views: 2,439
Posted By Sebringx
it's your logic 7 amp...... Same issues I had...

it's your logic 7 amp...... Same issues I had with mine
Forum: 7 Series - E65 / E66 (2002 - 2008) 01-31-2013, 06:21 PM
Replies: 22
Views: 2,665
Posted By Sebringx
Just replaced my Logic 7 amp....it took about...

Just replaced my Logic 7 amp....it took about 15-20 to replace amp. My subwoofers are working excellent now!!!!
Forum: 7 Series - E65 / E66 (2002 - 2008) 01-26-2013, 11:41 AM
Replies: 107
Views: 7,083
Posted By Sebringx
I have The I .....don't use the rear seat so it...

I have The I .....don't use the rear seat so it doesn't matter
Forum: 7 Series - E65 / E66 (2002 - 2008) 01-26-2013, 11:37 AM
Replies: 22
Views: 2,665
Posted By Sebringx
Hi! I found this on eBay and thought you might...

Hi! I found this on eBay and thought you might like it! "BMW OEM FACTORY AMPLIFIER L7 LOGIC 65-12-6-961-389 BMW TOP HIFI DSP SYSTEM AMP" http://r.ebay.com/uufoHX
Forum: 7 Series - E65 / E66 (2002 - 2008) 01-26-2013, 11:37 AM
Replies: 22
Views: 2,665
Posted By Sebringx
Here is the link::: I just a Ordered one for $250

Here is the link::: I just a Ordered one for $250
Forum: 7 Series - E65 / E66 (2002 - 2008) 01-26-2013, 11:35 AM
Replies: 22
Views: 2,665
Posted By Sebringx
Don't miss out on item BMW OEM FACTORY AMPLIFIER...

Don't miss out on item BMW OEM FACTORY AMPLIFIER L7 LOGIC65-12-6-961-389 BMW TOP HIFI DSP SYSTEM AMP (181068146593)
this on eBay
Forum: 7 Series - E65 / E66 (2002 - 2008) 01-14-2013, 05:05 PM
Replies: 22
Views: 2,665
Posted By Sebringx
Emeer18 it is l7 amp ....Rookie is so right. I...

Emeer18 it is l7 amp ....Rookie is so right. I have the same problems with mine. A INDY told it was the subwoofer ....NOT. Soon your Sub's will stop working all together ......it's RARE for Both subs...
Forum: 7 Series - E65 / E66 (2002 - 2008) 12-25-2012, 06:43 PM
Replies: 24
Views: 1,700
Posted By Sebringx
Buy it

Buy it
Forum: New Member Introductions 07-22-2012, 12:10 PM
Replies: 6
Views: 979
Posted By Sebringx
Trade it in asap!

Trade it in asap!
Forum: 7 Series - E65 / E66 (2002 - 2008) 07-22-2012, 11:41 AM
Replies: 5
Views: 558
Posted By Sebringx
Great link Rookie!

Great link Rookie!
Forum: 7 Series - E65 / E66 (2002 - 2008) 07-22-2012, 11:13 AM
Replies: 5
Views: 558
Posted By Sebringx
its located in the trunk, behind the left nav...

its located in the trunk, behind the left nav access panel on a silver "TCU" module about the size of 2 vhs tapes stacked together. if you look at the eject button on the nav player its located just...
Forum: 7 Series - E65 / E66 (2002 - 2008) 07-22-2012, 10:59 AM
Replies: 5
Views: 558
Posted By Sebringx
It's on the driver side in the trunk.... Near the...

It's on the driver side in the trunk.... Near the amp.

That is where your BT code is
Forum: 7 Series - E65 / E66 (2002 - 2008) 06-17-2012, 04:56 PM
Replies: 9
Views: 4,631
Posted By Sebringx
Try resetting the MOST BUS LOOP... It's in your...

Try resetting the MOST BUS LOOP... It's in your glove compartment ... Its little flip down door .... Disconnect it for ten seconds .... This controls all your I drive selections
Forum: 7 Series - E65 / E66 (2002 - 2008) 06-17-2012, 04:49 PM
Replies: 55
Views: 5,565
Posted By Sebringx
Congrats

Congrats
Forum: 7 Series - E65 / E66 (2002 - 2008) 07-18-2011, 06:28 PM
Replies: 20
Views: 6,707
Posted By Sebringx
A1 All German Car Corp 400 W 219th St New...

A1 All German Car Corp
400 W 219th St
New York
(212) 567-9706

They worked on my former 2003 745i
I rate them as excellent
Forum: 7 Series - E65 / E66 (2002 - 2008) 04-22-2011, 08:45 PM
Replies: 22
Views: 2,257
Posted By Sebringx
Make sure you get the right one for your car. If...

Make sure you get the right one for your car. If you have a curled cord attached to the unit in the center console you need the btum 8000.... No curled cord ....9000.
That all you need for Bluetooth...
Forum: E34 (1989 - 1995) 04-14-2011, 06:13 PM
Replies: 12
Views: 927
Posted By Sebringx
I had the same problem...it was the alternator...

I had the same problem...it was the alternator which needed to be replaced


Sent from my iPhone using BimmerApp
Forum: 7 Series - E65 / E66 (2002 - 2008) 04-12-2011, 05:22 PM
Replies: 105
Views: 6,404
Posted By Sebringx
Ahhhhh in MD ... Sounds like plan..... It will a...

Ahhhhh in MD ... Sounds like plan..... It will a nice 4 hour run with my summer tires


Sent from my iPhone using BimmerApp
Forum: 7 Series - E65 / E66 (2002 - 2008) 04-07-2011, 08:58 PM
Replies: 107
Views: 7,083
Posted By Sebringx
I man here ex 745i & present 750i never sat in...

I man here ex 745i & present 750i never sat in the backseat ... So I don't need a LI..


Sent from my iPhone using BimmerApp
Forum: 7 Series - E65 / E66 (2002 - 2008) 04-04-2011, 09:12 PM
Replies: 9
Views: 977
Posted By Sebringx
Brought mine from eBay also ...it's work great in...

Brought mine from eBay also ...it's work great in 07 750i....2010 map for $40


Sent from my iPhone using BimmerApp
Forum: 7 Series - E65 / E66 (2002 - 2008) 04-02-2011, 07:30 AM
Replies: 21
Views: 5,392
Posted By Sebringx
Never trust used 22's .....goto www.tirerack.com...

Never trust used 22's .....goto www.tirerack.com and see what they got.


Sent from my iPhone using BimmerApp
Forum: E36/7 Z3 (1996-2002) 03-20-2011, 07:29 AM
Replies: 6
Views: 2,345
Posted By Sebringx
Run and do not look back Sent from my...

Run and do not look back


Sent from my iPhone using BimmerApp
Forum: 7 Series - F01 / F02 (2009 - 2015) 03-20-2011, 01:21 AM
Replies: 7
Views: 1,880
Posted By Sebringx
I had a similar scratch on my black 745. Have it...

I had a similar scratch on my black 745. Have it buffed out .... Light compound & polish with a detailing machine


Sent from my iPhone using BimmerApp
Forum: 7 Series - E65 / E66 (2002 - 2008) 03-03-2011, 08:51 PM
Replies: 5
Views: 1,185
Posted By Sebringx
I had that problem before .... Delete the pairing...

I had that problem before .... Delete the pairing from your phone. Turn the iPhone completely off, then back on. Now pair it with your car again.


Sent from my iPhone using BimmerApp
Forum: 7 Series - E65 / E66 (2002 - 2008) 03-01-2011, 04:31 PM
Replies: 20
Views: 6,707
Posted By Sebringx
Excellent service for my former 2004 745i. ...

Excellent service for my former 2004 745i.
Check out the link

http://www.bbb.org/new-york-city/business-reviews/auto-repair-and-service/a-1-german-car-corp-in-new-york-ny-46153/#_rr


Sent...
Showing results 1 to 25 of 34

Forum Jump

All times are GMT -7. The time now is 08:04 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.