Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 12 of 12
Search took 0.25 seconds.
Search: Keyword(s): ; Posts Made By: yoman793
Forum: E39 (1997 - 2003) 10-05-2014, 07:19 AM
Replies: 30
Views: 999
Posted By yoman793
150! These engines are just getting worn in by...

150! These engines are just getting worn in by then. My buddy has over 300k on his 540.
Forum: E39 (1997 - 2003) 07-14-2014, 10:00 AM
Replies: 3
Views: 247
Posted By yoman793
^^^ See above. Hopefully its just a shot wire...

^^^ See above. Hopefully its just a shot wire from wheel speed sensor. Easy fix
Forum: E39 (1997 - 2003) 06-14-2014, 08:28 AM
Replies: 15
Views: 631
Posted By yoman793
Sounds like the dreaded thrust arm bushings. I...

Sounds like the dreaded thrust arm bushings. I had the same thing, shimmy at highway speeds. Not a bad diy either. Save yourself the $ and do it yourself and you get an excuse to spend some money at...
Forum: E39 (1997 - 2003) 06-13-2014, 09:32 PM
Replies: 9
Views: 330
Posted By yoman793
Just did the front pads and struts (amongst a...

Just did the front pads and struts (amongst a whole bunch of other things). Went ebc for the pads and oem for the struts. Bmw did it right the first time around and I was looking for that "factory...
Forum: E39 (1997 - 2003) 05-28-2014, 09:24 PM
Replies: 8
Views: 322
Posted By yoman793
Thanks guys. I'll snap a photo of the connector...

Thanks guys. I'll snap a photo of the connector and area tomorrow and post it up. Also i'll fire it up tomorrow and get the codes read. Just need to change the oil after that valve cover gasket job. ...
Forum: E39 (1997 - 2003) 05-28-2014, 11:48 AM
Replies: 8
Views: 322
Posted By yoman793
Misplaced electrical connector

Hey everyone. First off I gotta say how helpful this forum is! I just replaced struts, thrust arms, tie rods, sway bar links and brake pads up front all with help from the many diys I read up here....
Forum: E39 (1997 - 2003) 12-07-2012, 10:10 AM
Replies: 6
Views: 569
Posted By yoman793
200k! Impressive. Good luck with the repairs. ...

200k! Impressive. Good luck with the repairs. Been thinking of tackling the job on my 530 here soon.

Checked out your site. Looks like you have quite a bit of fun at work! :bow: Any chance...
Forum: E39 (1997 - 2003) 10-15-2012, 12:35 PM
Replies: 79
Views: 83,357
Posted By yoman793
^^^ great thread. thanks bluebee!

^^^ great thread. thanks bluebee!
Forum: E39 (1997 - 2003) 10-14-2012, 11:36 PM
Replies: 11
Views: 4,148
Posted By yoman793
ah ok. i took a look at it today and see what...

ah ok. i took a look at it today and see what you did. i think i can get at it easy enough. im gonna order that part on monday and give it a go. new plugs did help the car but did nothing for the...
Forum: E39 (1997 - 2003) 10-14-2012, 10:16 AM
Replies: 4
Views: 459
Posted By yoman793
^^^ see above. used a 3m kit from autozone with...

^^^ see above. used a 3m kit from autozone with great success. just a little wet sanding.
Forum: E39 (1997 - 2003) 10-14-2012, 10:04 AM
Replies: 11
Views: 4,148
Posted By yoman793
gonna be swapping out my knock sensor ASAP. ...

gonna be swapping out my knock sensor ASAP. posted on that other thread that this is the same thing that has been happening to me. I tried several other things attempting to find the problem. I'm...
Forum: E39 (1997 - 2003) 10-14-2012, 09:53 AM
Replies: 50
Views: 9,593
Posted By yoman793
Hate to revive such an old thread, but this is...

Hate to revive such an old thread, but this is the exact same problem i am having with my new to me 01 530i. I love the car to death but this issue has been bugging me for some time. The other day...
Showing results 1 to 12 of 12

Forum Jump

All times are GMT -7. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms