Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 2 of 2
Search took 0.21 seconds.
Search: Keyword(s): ; Posts Made By: bossman1
Forum: 7 Series - E38 (1995 - 2001) 10-28-2012, 05:58 PM
Replies: 6
Views: 1,292
Posted By bossman1
You could also try disconnecting your maf and see...

You could also try disconnecting your maf and see how the car runs.
If it runs better without the maf you need to either clean your current maf or buy a new one.
MAF problems are very common...
Forum: 7 Series - E38 (1995 - 2001) 10-28-2012, 05:51 PM
Replies: 2
Views: 468
Posted By bossman1
You should try disconnecting your Mass Air Flow...

You should try disconnecting your Mass Air Flow sensor and see how the vehicle runs.
If it tuns better without the maf you should clean your maf or get a new one.
Showing results 1 to 2 of 2

Forum Jump

All times are GMT -7. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms