Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 25
Search took 0.35 seconds.
Search: Keyword(s): ; Posts Made By: hyksos
Forum: X3 E83 (2004 - 2010) 11-10-2012, 02:46 PM
Replies: 14
Views: 4,385
Posted By hyksos
Great, on mine, the EML never came on .... I...

Great, on mine, the EML never came on .... I think they are using a damped EML :rofl:

Seriously, as soon as the engine go in protection mode, the EML should go on.
Forum: X3 E83 (2004 - 2010) 11-06-2012, 10:42 PM
Replies: 14
Views: 4,385
Posted By hyksos
I don't think the temperature gauge is that...

I don't think the temperature gauge is that bad... when it is -30 here in Canada, it take forever to reach center.

And when I got the overheat in traffic, I turned my A/C off and turned the heat...
Forum: X3 E83 (2004 - 2010) 11-06-2012, 09:49 PM
Replies: 14
Views: 4,385
Posted By hyksos
The fan was not working at all, but the X3 does...

The fan was not working at all, but the X3 does not overheat easily, even with the fan not working at all, the engine was keeping normal temperature 99% of the time, I only saw overheat when I was...
Forum: X3 E83 (2004 - 2010) 11-06-2012, 07:41 PM
Replies: 14
Views: 4,385
Posted By hyksos
oh and to test if your fan work, all you have to...

oh and to test if your fan work, all you have to do is start the engine and turn the A/C on at full power, open the hood, the fan should be running. (You can actually hear it outside without even...
Forum: X3 E83 (2004 - 2010) 11-06-2012, 07:36 PM
Replies: 14
Views: 4,385
Posted By hyksos
Oh, I forgot to update this thread. My...

Oh, I forgot to update this thread.

My problem was the radiator fan ..... it was not working anymore, I found it the hard way in the traffic, my engine temperature increased dramatically when I...
Forum: X3 E83 (2004 - 2010) 11-08-2011, 09:50 PM
Replies: 4
Views: 1,987
Posted By hyksos
my 07 X3 was doing something similar, each time I...

my 07 X3 was doing something similar, each time I removed my key from contact the rear hatch was released multiples time, like 5-6 time in a row, this was driving me crazy, it have drain my battery...
Forum: X3 E83 (2004 - 2010) 11-08-2011, 09:21 PM
Replies: 47
Views: 10,105
Posted By hyksos
I had similare problem. My cooling fan was...

I had similare problem.

My cooling fan was death, the engine was not overheating when I had hesitation... I discovered it much later (about 2-3 weeks) at a traffic jams, DOH!

The fan was...
Forum: X3 E83 (2004 - 2010) 06-05-2011, 09:36 AM
Replies: 6
Views: 1,221
Posted By hyksos
I have the same problem with my 2007 X3 3.0si.......

I have the same problem with my 2007 X3 3.0si....

It do it as well when I quickly accelerate from a stop, foot to the metal, engine rev up to redline then shift second gear, it totally stale and...
Forum: X3 E83 (2004 - 2010) 06-03-2011, 05:51 PM
Replies: 17
Views: 7,006
Posted By hyksos
why are you all suggesting its a freon problem???...

why are you all suggesting its a freon problem??? it's cold on the driver side so freon seem to work!

I dunno, maybe the vent is not open on the passenger side?? :)

Also, the middle vent have...
Forum: X3 E83 (2004 - 2010) 05-31-2011, 10:41 PM
Replies: 34
Views: 3,517
Posted By hyksos
There's many full synthetic oil on the market,...

There's many full synthetic oil on the market, Amsoil (only there XL product are group III), Royal Purple, Motul, some Mobile 1 and the Shell Rotella T to name a few.

The main purpose of synthetic...
Forum: X3 E83 (2004 - 2010) 05-30-2011, 07:27 AM
Replies: 14
Views: 4,385
Posted By hyksos
After some test with my ODBC reader, the MAF seem...

After some test with my ODBC reader, the MAF seem working perfectly.

But I found something very strange with the throttle position... its value decrease dramatically when my power loss occur, but...
Forum: X3 E83 (2004 - 2010) 05-29-2011, 10:23 AM
Replies: 14
Views: 4,385
Posted By hyksos
I have an extended warranty on it but not from...

I have an extended warranty on it but not from BMW ... and they are very picky about doing repair, if it don't throw a code and is still drivable they won't do a thing, unless I have solid proof that...
Forum: X3 E83 (2004 - 2010) 05-29-2011, 08:58 AM
Replies: 14
Views: 4,385
Posted By hyksos
So, no one else had this problem? :(

So, no one else had this problem? :(
Forum: X3 E83 (2004 - 2010) 05-28-2011, 05:48 PM
Replies: 34
Views: 3,517
Posted By hyksos
Even for mineral oil 3000 miles is a waste,...

Even for mineral oil 3000 miles is a waste, mineral can be changed at 5000-7000 miles no problem, synthetic last a LOT longer, some can last 50 000 miles ... and the oil company back their claim,...
Forum: X3 E83 (2004 - 2010) 05-28-2011, 08:11 AM
Replies: 9
Views: 2,215
Posted By hyksos
Maybe it had the sport package? The 07-10...

Maybe it had the sport package?

The 07-10 with sport package have the same stiffness then the 04-06 with non sport package, but the 07-10 non sport have a softer ride.
Forum: X3 E83 (2004 - 2010) 05-28-2011, 07:56 AM
Replies: 9
Views: 2,215
Posted By hyksos
Did you check if the 2007+ shock and spring are...

Did you check if the 2007+ shock and spring are compatible with the 2004-2006? They are a lot softer then yours (The non sport-m)
Forum: X3 E83 (2004 - 2010) 05-27-2011, 09:56 PM
Replies: 9
Views: 2,215
Posted By hyksos
Check your tire pressure too, too often they have...

Check your tire pressure too, too often they have lot more psi then needed. Do not put the max psi written on the tire, use the psi recommended by bmw. (inside driver door)
Forum: X3 E83 (2004 - 2010) 05-27-2011, 09:01 PM
Replies: 8
Views: 2,519
Posted By hyksos
the stability control use braking, but traction...

the stability control use braking, but traction control use fuel control.

Have you ever tried it on snow or ice?? Stability control is still on when the DTC is off, the wheel spin freely but the...
Forum: X3 E83 (2004 - 2010) 05-27-2011, 08:10 PM
Replies: 8
Views: 2,519
Posted By hyksos
DTC button is not turning xDrive on/off, it only...

DTC button is not turning xDrive on/off, it only turn off the electronics that control the throttle when there's wheel spin, when it detect a spin it will automatically cut gas.

You have to try it...
Forum: X3 E83 (2004 - 2010) 05-27-2011, 07:50 PM
Replies: 14
Views: 4,385
Posted By hyksos
More info, this is not due to gas quality, the...

More info, this is not due to gas quality, the engine idle perfectly, very steady and since the first time it happened, I went through at least 2 full tank of gas, always premium.
Forum: X3 E83 (2004 - 2010) 05-27-2011, 07:43 PM
Replies: 14
Views: 4,385
Posted By hyksos
Intermittent power loss, fuel pump problem?

About a month ago I had a check engine, coil pack #6 gone bad, the engine was vibrating and had no power, replaced the coil pack, check engine gone, no more vibration, power was back.

But after...
Forum: X3 E83 (2004 - 2010) 04-26-2011, 06:05 PM
Replies: 1,736
Views: 345,577
Posted By hyksos
I have a 2007 X3 3.0si. I really love it, I...

I have a 2007 X3 3.0si.

I really love it, I noticed some little lag from the throttle, but nothing too bad, but today I saw something very strange when I tested if my new coil pack worked well.
...
Forum: X3 E83 (2004 - 2010) 04-26-2011, 05:55 PM
Replies: 5
Views: 3,378
Posted By hyksos
#6 cylinder's coil pack replaced... everything is...

#6 cylinder's coil pack replaced... everything is back to normal! :thumbup:
Forum: X3 E83 (2004 - 2010) 04-25-2011, 02:34 PM
Replies: 5
Views: 3,378
Posted By hyksos
nope, I thought it was the auto transmission as...

nope, I thought it was the auto transmission as well, so I switched to manuel mode and downshifted manually, the rpm went up but still no power, I had the foot to the metal, engine at 4000rpm and...
Forum: X3 E83 (2004 - 2010) 04-25-2011, 08:55 AM
Replies: 5
Views: 3,378
Posted By hyksos
Massive loss of power, code P0306

Hi all, I'm the new owner of a BMW X3 3.0si 2007, I totally love it, but the other day on the highway, I had a massive loss of power, I could barely accelerate, could not get over 40mph... and the...
Showing results 1 to 25 of 25

Forum Jump

All times are GMT -7. The time now is 05:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms