Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 647
Search took 0.54 seconds.
Search: Keyword(s): ; Posts Made By: kenza
Forum: X3 E83 (2004 - 2010) 07-28-2015, 08:34 AM
Replies: 2
Views: 209
Posted By kenza
Steering wheel replacement

Hi everyone!

After 220K kms, the leather on my steering wheel started to peel off where my left hand normally is (at 10 o'clock).

I found a new steering wheel on eBay:
...
Forum: X3 E83 (2004 - 2010) 07-13-2015, 02:58 PM
Replies: 7
Views: 379
Posted By kenza
BTW, take a look at this thread:...

BTW, take a look at this thread: http://www.bimmerfest.com/forums/showthread.php?t=842922
Forum: X3 E83 (2004 - 2010) 07-13-2015, 02:57 PM
Replies: 9
Views: 676
Posted By kenza
Ccon, I guess the sensor is not picking up...

Ccon, I guess the sensor is not picking up differences based on having a nail, it probably detects only the pressure difference, hence the diameter diff also. Good luck.
Forum: X3 E83 (2004 - 2010) 07-13-2015, 02:53 PM
Replies: 7
Views: 379
Posted By kenza
How are your tires? All 4 worn equally? Same...

How are your tires? All 4 worn equally? Same pressure?

Check rear right tire, it may have a nail in it.
Forum: X3 E83 (2004 - 2010) 07-13-2015, 02:48 PM
Replies: 12
Views: 544
Posted By kenza
Unfortunately you have either to change all 4...

Unfortunately you have either to change all 4 tires at the same time or get the new ones shaven to the same diameter as the old ones.
Forum: X3 E83 (2004 - 2010) 06-23-2015, 07:21 AM
Replies: 9
Views: 676
Posted By kenza
Ccon, did you check the tire pressure? When you...

Ccon, did you check the tire pressure? When you patched the tire, it is possible they did not inflate it to the same pressure. X3s are very, very, very sensitive to tire wear and pressure.

BTW, I...
Forum: X3 E83 (2004 - 2010) 06-23-2015, 07:10 AM
Replies: 12
Views: 544
Posted By kenza
Btw, did you change all 4 tires? The pressure in...

Btw, did you change all 4 tires? The pressure in them is the same?
Forum: X3 E83 (2004 - 2010) 05-19-2015, 08:10 AM
Replies: 9
Views: 676
Posted By kenza
Before doing anything, check your tires. There is...

Before doing anything, check your tires. There is a chance you might have something (nail, screw, etc) in one of tires. It happened to me couple of times and symptoms were the same.
Forum: X3 E83 (2004 - 2010) 05-19-2015, 08:08 AM
Replies: 2
Views: 377
Posted By kenza
Yes, as Blueskye said, there is something wrong...

Yes, as Blueskye said, there is something wrong with the leveling sensors. Take a look and reconnect them.
Forum: X3 E83 (2004 - 2010) 02-23-2015, 06:04 PM
Replies: 18
Views: 1,183
Posted By kenza
Good luck UncleJ! All the best!

Good luck UncleJ! All the best!
Forum: X3 E83 (2004 - 2010) 02-03-2015, 02:55 PM
Replies: 30
Views: 1,406
Posted By kenza
Well, this is true but somehow I am on my third...

Well, this is true but somehow I am on my third clutch (MT) at 200.000kms. The first one was killed by a bowrider boat whose trailer was stuck in the mud. The second one was almost ok but was making...
Forum: X3 E83 (2004 - 2010) 01-24-2015, 07:57 AM
Replies: 629
Views: 227,961
Posted By kenza
Here is what my old gear looked like. 488325...

Here is what my old gear looked like.

488325

I did not remove the actuator motor, just pried off the plate. Entire job took around an hour.

Thanks guys, this forum is great, as it has always...
Forum: X3 E83 (2004 - 2010) 01-24-2015, 07:53 AM
Replies: 25
Views: 921
Posted By kenza
Ok, it took me around an hour to replace the...

Ok, it took me around an hour to replace the gear. Lights went away and did not appear during the off-road test I did.

I did not need to remove the actuator motor (opposite to some you tube videos...
Forum: X3 E83 (2004 - 2010) 01-23-2015, 02:05 PM
Replies: 25
Views: 921
Posted By kenza
I changed the T-case fluid at 200K kms (and...

I changed the T-case fluid at 200K kms (and previously at 100K), so it should not be the problem.
Forum: X3 E83 (2004 - 2010) 01-23-2015, 02:03 PM
Replies: 25
Views: 921
Posted By kenza
No, did not hear the clicking sound. But, have...

No, did not hear the clicking sound. But, have not had grease on my hands lately, so will do it anyway :)
Forum: X3 E83 (2004 - 2010) 01-23-2015, 04:11 AM
Replies: 25
Views: 921
Posted By kenza
This morning the lights went off. I did find the...

This morning the lights went off. I did find the gear and will probably replace it tomorrow, just in case. It does not look complicated, will probably take 1-1.5hrs.
Forum: X3 E83 (2004 - 2010) 01-22-2015, 07:53 PM
Replies: 25
Views: 921
Posted By kenza
UncleJ, just got the terrible triad myself. First...

UncleJ, just got the terrible triad myself. First real problem in 203.000kms (besides a window drive dog).

Anyway, just need to find the actuator gear (20 bucks) I purchased a couple of months...
Forum: X3 E83 (2004 - 2010) 01-12-2015, 01:30 PM
Replies: 16
Views: 1,374
Posted By kenza
I just pre-ordered on Amazon. Hope it will be out...

I just pre-ordered on Amazon. Hope it will be out on time.
Forum: X3 E83 (2004 - 2010) 12-29-2014, 12:49 PM
Replies: 11
Views: 2,432
Posted By kenza
I just replaced my MT oil, it took less than 2...

I just replaced my MT oil, it took less than 2 quarts.
Forum: X3 E83 (2004 - 2010) 12-29-2014, 04:00 AM
Replies: 16
Views: 1,374
Posted By kenza
Has anyone seen the book?

Has anyone seen the book?
Forum: X3 E83 (2004 - 2010) 11-23-2014, 04:06 AM
Replies: 15
Views: 2,783
Posted By kenza
Here is the picture that shows what happened with...

Here is the picture that shows what happened with the original tstat. Must be the same problem with the second one...

477519
Forum: X3 E83 (2004 - 2010) 11-23-2014, 02:59 AM
Replies: 15
Views: 2,783
Posted By kenza
When I replaced the tstat on my car (with the...

When I replaced the tstat on my car (with the geniune OEM BMW one), the new one lasted for a month and died. Have been driving like this for a year.

Any similar experiences here?
Forum: BMW i3 and BMW i8 (2014 - Current) 11-17-2014, 10:27 AM
Replies: 3
Views: 592
Posted By kenza
DRP, when I did the test drive, I was able to get...

DRP, when I did the test drive, I was able to get to 95MPH easily. The problem is the car is not capable of doing more, but I think keeping the top speed is perfectly doable. Of course, your SOC will...
Forum: X3 E83 (2004 - 2010) 11-10-2014, 12:37 PM
Replies: 5
Views: 443
Posted By kenza
Broken rear springs?

Broken rear springs?
Forum: X3 E83 (2004 - 2010) 11-03-2014, 11:28 AM
Replies: 4
Views: 479
Posted By kenza
Done it multiple times both ways. Never had any...

Done it multiple times both ways. Never had any issues.
Showing results 1 to 25 of 647

Forum Jump

All times are GMT -7. The time now is 05:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms