Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 13 of 13
Search took 2.54 seconds.
Search: Keyword(s): ; Posts Made By: WC5150
Forum: E34 (1989 - 1995) 04-30-2013, 01:02 AM
Replies: 4
Views: 237
Posted By WC5150
Question Thanx for the feed back..

I wish i was just messing around and trying some mods! But sadly i blew a head gasket a couple of weeks ago. I was out of town with my fam. The car was running strong, just changed the oil, put some...
Forum: E34 (1989 - 1995) 04-29-2013, 09:14 PM
Replies: 4
Views: 237
Posted By WC5150
Unhappy Need some good luck

:banghead: found a engine that i needed, talked to the seller, $ 300... Last minute seller tells me that his landlord scraped it without telling him! I guess he has been told to get rid of it a...
Forum: E34 (1989 - 1995) 04-12-2013, 01:12 PM
Replies: 2
Views: 220
Posted By WC5150
OK! Thanks..:thumbup:

OK! Thanks..:thumbup:
Forum: E34 (1989 - 1995) 04-11-2013, 10:25 AM
Replies: 11
Views: 2,204
Posted By WC5150
I had the same problem one time, only, not only...

I had the same problem one time, only, not only did the locking system not work, but my car wouldn't start! All I did to fix the problem was I disconnected the battery terminals for 2 seconds and...
Forum: E34 (1989 - 1995) 04-11-2013, 10:12 AM
Replies: 2
Views: 220
Posted By WC5150
Angry Update on my problem

:bawling: well I put some gasket sealer in my car, crossed my fingers, and proceeded to make my way back home!:eek: But as expected, I think I might have blown my engine :mad: Because my car kept...
Forum: E34 (1989 - 1995) 04-05-2013, 04:19 AM
Replies: 9
Views: 402
Posted By WC5150
UPDATE!! Fixed the Intake Thermostat. But now...

UPDATE!! Fixed the Intake Thermostat. But now realized that I did end up blowing a head gasket, because there is water in my oil! So Im just gonna try and make it home! I don't think that I cracked...
Forum: E34 (1989 - 1995) 04-04-2013, 12:20 PM
Replies: 9
Views: 402
Posted By WC5150
I looked up the part number online. And it said...

I looked up the part number online. And it said that's what it was called. there are no wires to it, so if it was to fail it would not register on the dash message. The only thing that goes to it is...
Forum: E34 (1989 - 1995) 04-03-2013, 11:18 PM
Replies: 9
Views: 402
Posted By WC5150
Sorry! I don't have any pictures at the moment....

Sorry! I don't have any pictures at the moment. But the fitting that I bypassed was the" Intake Thermostat"! The two hoses that went to it, I disconnected them and hooked them up together to bypass...
Forum: E34 (1989 - 1995) 04-03-2013, 10:22 PM
Replies: 9
Views: 402
Posted By WC5150
Cool 95 525i running rough after overheating!HELP

My car broke 2 hoses. These hoses connected to a sensor that goes into the air filter box. The fitting broke at the nipples for the hoses! I'm out of town with my family, and need help figuring this...
Forum: E46 (1999 - 2006) 04-03-2013, 09:58 PM
Replies: 14
Views: 11,170
Posted By WC5150
My 525i over heated due to a coolant hose. Fixed...

My 525i over heated due to a coolant hose. Fixed it. But now my car runs rough. Any ideas? The hoses that broke went to a sensor that goes onto the air filter box, so now i bypassed that and hooked...
Forum: E34 (1989 - 1995) 09-28-2012, 03:57 PM
Replies: 4
Views: 1,205
Posted By WC5150
Cool Okay! Thanx.

Thanks For the feed back! I will try all.....:thumbup: By the way,has anyone upgraded thief 525i with "Angel Eye" projector headlights?:confused: I bought some and was wondering if there is anything...
Forum: E34 (1989 - 1995) 09-28-2012, 10:20 AM
Replies: 4
Views: 1,205
Posted By WC5150
Question Vibration when accelerating?

It seems when i accelerate from a stop, I get a bad thumping/vibration,that can be felt around the center/rear of the car.:eek: After 20-30mph,it goes away,and dives smooth again! Could it be a...
Forum: E34 (1989 - 1995) 09-26-2012, 11:27 PM
Replies: 2
Views: 632
Posted By WC5150
Cool Hello! I'm new to this Site,have a serious question!

I have a problem. I just bought a 1995 525i about 5 months ago. The car drives great,and I couldn't be happier. But now I have to get it smogged. It has failed twice,and the mech. Said it was due to...
Showing results 1 to 13 of 13

Forum Jump

All times are GMT -7. The time now is 09:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms