Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 88
Search took 0.65 seconds.
Search: Keyword(s): ; Posts Made By: babo
Forum: General BMW 05-11-2014, 11:53 AM
Replies: 2
Views: 326
Posted By babo
Thumbs down no more wiper refills?

am i missing something or _all_ local stores ( 07601) discontinued wiper blade refills _at all_?
nobody carries just a simple cheap refills - i've been buying those for years for a few bucks and...
Forum: X3 E83 (2004 - 2010) 01-18-2014, 10:17 AM
Replies: 22
Views: 906
Posted By babo
Yup did that too. Sent from my SGH-T989...

Yup did that too.

Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 01-18-2014, 09:29 AM
Replies: 22
Views: 906
Posted By babo
I took the cover (black silver plastic) off. It...

I took the cover (black silver plastic) off. It was on two bolts and two nuts. Took the wiring for plugs and xabel for O2 sensor out.
Took plugs out obviously.
When I took those 11 nuts out there...
Forum: X3 E83 (2004 - 2010) 01-18-2014, 07:13 AM
Replies: 22
Views: 906
Posted By babo
Thats one is for n52 enigine. Seemed to be very...

Thats one is for n52 enigine. Seemed to be very different than mine which is m54 ( https://en.m.wikipedia.org/wiki/BMW_M54)

I followed this one - http://youtu.be/frl1eUKtkus

Sent from my...
Forum: X3 E83 (2004 - 2010) 01-17-2014, 09:59 PM
Replies: 22
Views: 906
Posted By babo
I was not able to pry the gasket open. there...

I was not able to pry the gasket open.
there were 11 bolts around the gasket and 3 or 4 in the center where the plugs were.
What did i miss?:dunno:
Forum: X3 E83 (2004 - 2010) 01-16-2014, 08:05 AM
Replies: 17
Views: 1,187
Posted By babo
Well apparently I didnt plug the connector ibto...

Well apparently I didnt plug the connector ibto the socket so there was no sound from iphone. :rolleyes:
But now both phones work great.
Thank you gentlemen.

Sent from my SGH-T989 using...
Forum: X3 E83 (2004 - 2010) 01-15-2014, 01:59 PM
Replies: 17
Views: 1,187
Posted By babo
Haven't tried charging. Let me check and ill...

Haven't tried charging. Let me check and ill report back


Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 01-15-2014, 08:05 AM
Replies: 22
Views: 906
Posted By babo
Gents, you were right - i found valve gasket...

Gents, you were right - i found valve gasket leaking and i think oil gasket leaking too. The local shop asked $800 in repairs. I plan to do VG myself once the weather is cooperating. Not sure about...
Forum: X3 E83 (2004 - 2010) 01-15-2014, 08:01 AM
Replies: 17
Views: 1,187
Posted By babo
Finally got around to install the AUX. G2 works...

Finally got around to install the AUX. G2 works fine, Iphone 5s doesn't. no idea why.
here is the link to my post http://www.xoutpost.com/bmw-sav-forums/x3-e83-forum/95595-aux-input-navi.html
Forum: X3 E83 (2004 - 2010) 12-30-2013, 10:29 AM
Replies: 22
Views: 906
Posted By babo
Re: Smelly heat

Hmm... I replaced spark plugs last year and I did notice oil on one of them.
There is no smell under the hood when I pop it. But again smell goes away rather fast - 2 minutes.
I'll proceed with the...
Forum: X3 E83 (2004 - 2010) 12-29-2013, 01:10 PM
Replies: 22
Views: 906
Posted By babo
Re: Smelly heat

Its like a burning candle. If you ever been to a small church full of burning candles. I think that's the smell.
Also sometimes like plastic.

Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 12-28-2013, 09:40 AM
Replies: 22
Views: 906
Posted By babo
Smelly heat

Happy holidays!

Irregularly , mostly after 40-60 minutes of heat been on, nasty smell of something burning comes into the cabin. If I turn heat off and wait maybe 10 minutes before turning it back...
Forum: E36 (1991 - 1999) 09-09-2013, 10:06 AM
Replies: 12
Views: 539
Posted By babo
Re: dollar tied to cruse controll

Yeah. Russians also do that - tie bills. Never heard of coins on the floor as a deliberate attempt to make vacuum guys happier ;)

Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 09-09-2013, 09:53 AM
Replies: 17
Views: 1,187
Posted By babo
Re: Android/iPhone with 2006 BMW -music

I'm one silly monkey - there is no aux in the arm rest..
I was so sure there was one I never actually checked....
Embarrassing feeling to say the least....

Sent from my SGH-T989 using BimmerApp...
Forum: X3 E83 (2004 - 2010) 08-16-2013, 11:14 AM
Replies: 17
Views: 1,187
Posted By babo
Re: Android/iPhone with 2006 BMW -music

I have s2. No plans to change it for next year or so. But thank you.

Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 08-16-2013, 10:24 AM
Replies: 17
Views: 1,187
Posted By babo
Re: Android/iPhone with 2006 BMW -music

I like this one. Thank you!
Kids, wives and wires are not a stable situation.
Update:
Checked reviews on amazon - doesn't look that good. 25 out of total 80 gave 1star.
The next up the price is...
Forum: X3 E83 (2004 - 2010) 08-16-2013, 08:40 AM
Replies: 17
Views: 1,187
Posted By babo
Re: Android/iPhone with 2006 BMW -music

Cool. I'll try this approach then.

Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 08-16-2013, 07:23 AM
Replies: 17
Views: 1,187
Posted By babo
Re: Android/iPhone with 2006 BMW -music

Thank you for the link.
I was thinking maybe I can just use phone audio out to car's aux by a simple 3.5 mm wire?
Get a wire from amazon for $5 or so with two male connectors?
Whats the down side...
Forum: X3 E83 (2004 - 2010) 08-15-2013, 01:46 PM
Replies: 17
Views: 1,187
Posted By babo
Re: Android/iPhone with 2006 BMW -music

Thank you very much for the information.
I just looked this one up and it runs at ~$200 on amazon.
A bit steep price for plating music for me.

Anything on less expensive side?

Sent from my...
Forum: X3 E83 (2004 - 2010) 08-11-2013, 09:11 AM
Replies: 17
Views: 1,187
Posted By babo
Android/iPhone with 2006 BMW -music

Is there a way to get either android or iPhone to play music thru speakers of pre-idrive x3 (2006) ?
Did a quick search but most posts are about idrive integration.
Thank you
AZ

Sent from my...
Forum: X3 E83 (2004 - 2010) 07-06-2013, 05:09 PM
Replies: 5
Views: 320
Posted By babo
Re: wont start. wont hold rpm. odd sound from new wirewall

Yeah did that. Now, once all back to normal , that test passed - just idling changes.

Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 07-06-2013, 04:19 PM
Replies: 5
Views: 320
Posted By babo
Re: wont start. wont hold rpm. odd sound from new wirewall

They thought its ccv. But I told them it got replaced in feb this year.

Is there a way to validate your idea?


Sent from my SGH-T989 using BimmerApp mobile app
Forum: X3 E83 (2004 - 2010) 07-06-2013, 01:01 PM
Replies: 5
Views: 320
Posted By babo
Re: wont start. wont hold rpm. odd sound from new wirewall

Well and after I wasted 3 hours at mechanic waiting for him to take me in. It started on its own. Computer is clean. They dobt want to do anything and suggested me to take it for diagnosis to a...
Forum: X3 E83 (2004 - 2010) 07-06-2013, 06:59 AM
Replies: 5
Views: 320
Posted By babo
wont start. wont hold rpm. odd sound from new wirewall

this same problem with car refusing to start and not holding rpm came back this year. this time I noticed an odd sound from near the firewall.
any ideas are welcome.
here is a link to video I took....
Forum: X3 E83 (2004 - 2010) 06-21-2013, 07:38 AM
Replies: 3
Views: 547
Posted By babo
finally got to his . First measure on the...

finally got to his

. First measure on the high port gave me a reading of 135Kpa ( in shadow, all vents blowing, ambient temp 80F ). I got seriously concern that something maybe broken.

Took to...
Showing results 1 to 25 of 88

Forum Jump

All times are GMT -7. The time now is 09:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms