Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 6 of 6
Search took 0.29 seconds.
Search: Keyword(s): ; Posts Made By: beamer528e
Forum: E28 (1982 - 1988) 05-27-2014, 04:21 PM
Replies: 5
Views: 481
Posted By beamer528e
hey thanks. So what you're telling me is that...

hey thanks. So what you're telling me is that the new caliper I put on there was a dud? If that's the case don't order from brakeperformance. I just found out they messed up on drilling the lug...
Forum: E28 (1982 - 1988) 05-24-2014, 03:08 PM
Replies: 5
Views: 481
Posted By beamer528e
Right rear brake binding

I just replaced the caliper, flushed system, (but I didn't replace pads or rotor yet since I wanted to see if it was still binding and didn't want to waste a brand new rotor) and it is still scraping...
Forum: E28 (1982 - 1988) 01-25-2013, 10:04 AM
Replies: 9
Views: 1,022
Posted By beamer528e
I've been looking at used engines and heard an 84...

I've been looking at used engines and heard an 84 325 has the same engine as a 84 528 is this correct?
Forum: E28 (1982 - 1988) 01-22-2013, 12:58 PM
Replies: 9
Views: 1,022
Posted By beamer528e
Thanks I'll try that. However I just found out...

Thanks I'll try that. However I just found out today that my gasket wasn't the problem. I might have a cracked head or block. I had the head milled but didn't have it inspected for cracks. ...
Forum: E28 (1982 - 1988) 01-18-2013, 10:44 AM
Replies: 9
Views: 1,022
Posted By beamer528e
I recently read on another post a similar problem...

I recently read on another post a similar problem and the solution was switching the wires on the coolant temp switch. I did this and the high idle has been fixed, but now I've noticed it has an...
Forum: E28 (1982 - 1988) 01-17-2013, 11:30 AM
Replies: 9
Views: 1,022
Posted By beamer528e
Idle problem

I have an 84 528e. The idle speed is a little high. I noticed a vaccum hose disconnected and when I reattached the hose the idle went down. The next day It started doing it again and I inspected...
Showing results 1 to 6 of 6

Forum Jump

All times are GMT -7. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms