Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 25 of 244
Search took 0.55 seconds.
Search: Keyword(s): ; Posts Made By: ncord
Forum: X3 E83 (2004 - 2010) 07-17-2016, 04:45 AM
Replies: 6
Views: 415
Posted By ncord
I just removed the casing on my passenger side...

I just removed the casing on my passenger side mirror and found a extra wire that wasn`t connected to anything. I`m assuming this is for the folding mirror feature? My mirror has stopped working...
Forum: X3 E83 (2004 - 2010) 07-13-2016, 03:04 AM
Replies: 7
Views: 472
Posted By ncord
I replaced both springs on my 06 X3 last year.The...

I replaced both springs on my 06 X3 last year.The scissor worked fairly good,but if you undo
the shock at the bottom a long pry bar will help you get the spring in & out.I hope you are doing both...
Forum: X3 E83 (2004 - 2010) 07-02-2016, 04:04 AM
Replies: 37
Views: 1,664
Posted By ncord
Car has been checked completely.All bushings are...

Car has been checked completely.All bushings are tight ,shock seems to work on normal bumps,spring is seated properly. Bottoming sound happens more when I hit a hole or dip in the road causing the...
Forum: X3 E83 (2004 - 2010) 06-28-2016, 05:23 AM
Replies: 14
Views: 582
Posted By ncord
When mine started it thru the code for the cps...

When mine started it thru the code for the cps first.But when I replaced it the problem was still there.After cleaning the solenoid a couple of times it would improve for a couple of days.
I then...
Forum: X3 E83 (2004 - 2010) 06-28-2016, 04:16 AM
Replies: 14
Views: 582
Posted By ncord
Had the same problem with my 06 M54. I replaced...

Had the same problem with my 06 M54. I replaced the camshaft ps. (exhaust side)as well as the exhaust solenoid,and problem solved. Good luck.
Forum: General BMW Questions 06-28-2016, 03:15 AM
Replies: 56
Views: 14,786
Posted By ncord
I have the same clunk on one side rear.New shocks...

I have the same clunk on one side rear.New shocks & springs 8k mi.ago. Did you find a solution yet???
Forum: X3 E83 (2004 - 2010) 06-22-2016, 08:29 AM
Replies: 37
Views: 1,664
Posted By ncord
Checked everything again.Bump stop looks good...

Checked everything again.Bump stop looks good ,shock is dry,spring and pads are good and everything else seems to be in order.Here we go with another BMW mystery.:rofl::rolleyes:
Forum: X3 E83 (2004 - 2010) 06-22-2016, 03:07 AM
Replies: 37
Views: 1,664
Posted By ncord
I re-used the old ones as they looked to be in...

I re-used the old ones as they looked to be in good shape.However I will have a better
look and make sure they are still good. Thanks for your help.
Forum: X3 E83 (2004 - 2010) 06-21-2016, 10:39 AM
Replies: 37
Views: 1,664
Posted By ncord
Yes I put new top & bottom rubbers in,and all new...

Yes I put new top & bottom rubbers in,and all new shock mounts as well.
I usually buy all my parts while I am down south in the winter.To order them and have them
shipped to Canada is not worth it...
Forum: X3 E83 (2004 - 2010) 06-21-2016, 07:54 AM
Replies: 37
Views: 1,664
Posted By ncord
Used the Lesjofor springs # 4208450 .Made the...

Used the Lesjofor springs # 4208450 .Made the trip to Florida and back with no problem.
When I bounce the car up and down,everything seems tight and no noise.But when I hit a bump with passenger...
Forum: X3 E83 (2004 - 2010) 06-21-2016, 03:55 AM
Replies: 37
Views: 1,664
Posted By ncord
Replaced exhaust solenoid and cleared code. After...

Replaced exhaust solenoid and cleared code. After 4 days & over 200 mi.,car is running great and SES light has not returned. Dealer was only place that had valve for $250. Thanks for all your...
Forum: X3 E83 (2004 - 2010) 06-17-2016, 03:15 AM
Replies: 0
Views: 251
Posted By ncord
Rear Suspension

My 06 X3 has thumping noise (like bottoming out) on passenger side rear when I hit bumps.
Checked rear shocks & springs,(replaced 8K miles ago). All seem good. What could be causing thump? Thx.
Forum: X3 E83 (2004 - 2010) 06-08-2016, 03:57 AM
Replies: 5
Views: 468
Posted By ncord
Hepu water pump (metal impellar) & Reinz hoses. I...

Hepu water pump (metal impellar) & Reinz hoses. I think the Thermostat was Mahle.
Forum: X3 E83 (2004 - 2010) 06-08-2016, 03:34 AM
Replies: 37
Views: 1,664
Posted By ncord
Well, smooth running was short lived.Ten minutes...

Well, smooth running was short lived.Ten minutes into a trip and the car stalled,SES light came on & idle became rough .I think the exhaust solenoid is bad.Will try and find a replacement.The...
Forum: X3 E83 (2004 - 2010) 06-07-2016, 04:33 AM
Replies: 37
Views: 1,664
Posted By ncord
After my last rant,I went looking for a local...

After my last rant,I went looking for a local supplier for the solenoid.While out I took the car on a empty highway and really booted it for a while. would you believe the idle is now perfect and all...
Forum: X3 E83 (2004 - 2010) 06-06-2016, 02:57 AM
Replies: 37
Views: 1,664
Posted By ncord
Any more cures to the P0014 problem.I`m ready to...

Any more cures to the P0014 problem.I`m ready to drive this BMW piece of @#&% into the lake.
Forum: X3 E83 (2004 - 2010) 06-04-2016, 02:59 AM
Replies: 37
Views: 1,664
Posted By ncord
I have removed and cleaned both solenoids.Seem to...

I have removed and cleaned both solenoids.Seem to be moving free.How do you test them?
Forum: X3 E83 (2004 - 2010) 06-04-2016, 02:52 AM
Replies: 5
Views: 468
Posted By ncord
Just did my 06 X3.Purchased all parts from e...

Just did my 06 X3.Purchased all parts from e Europarts.SKU: 11517527910 - Qty: 1 of 1 - Price (ea): $53.49
Item: Engine Water Pump (w/ Metal Impeller)

SKU: 13621433077 - Qty: 1 of 1 - Price (ea):...
Forum: X3 E83 (2004 - 2010) 06-03-2016, 03:08 AM
Replies: 37
Views: 1,664
Posted By ncord
Replaced the exhaust CPS and cleaned the exhaust...

Replaced the exhaust CPS and cleaned the exhaust side solenoid.Also re-cleaned the Maff. Car ran great for about 20 minutes and then started idling rough again and thru code P0014 and P0015. I don`t...
Forum: X3 E83 (2004 - 2010) 05-28-2016, 03:06 AM
Replies: 37
Views: 1,664
Posted By ncord
Just re-checked and P0017 has gone and replaced...

Just re-checked and P0017 has gone and replaced with P0014.Whats going on???Didn`t do anything yet.
Forum: X3 E83 (2004 - 2010) 05-24-2016, 11:26 AM
Replies: 37
Views: 1,664
Posted By ncord
M54

M54
Forum: X3 E83 (2004 - 2010) 05-24-2016, 11:26 AM
Replies: 37
Views: 1,664
Posted By ncord
m54

m54
Forum: X3 E83 (2004 - 2010) 05-24-2016, 02:45 AM
Replies: 37
Views: 1,664
Posted By ncord
Rough idle

06 X3 115k miles. Car runs good but has rough idle and throwing code P0017.Cleaned solenoids and cps. CVV system seems to be good. Could it be a dirty idle control valve? Plugs, coils, & Oxygen...
Forum: X3 E83 (2004 - 2010) 05-15-2016, 03:15 AM
Replies: 13
Views: 711
Posted By ncord
Is your fan coming on? The sensor for it is on...

Is your fan coming on? The sensor for it is on your lower rad hose just before the rad connection.
Forum: X3 E83 (2004 - 2010) 04-27-2016, 10:25 AM
Replies: 1
Views: 286
Posted By ncord
Rough idle Code P0014

Just finished replacing water pump,thermostat and OFHG on 06 X3 115,000mi.
Run good for 20 mins.then started vibrating at idle and SES lite come on.Code
reader showing P0014 .Something to do with...
Showing results 1 to 25 of 244

Forum Jump

All times are GMT -7. The time now is 10:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms