Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 2 of 2
Search took 0.74 seconds.
Search: Keyword(s): ; Posts Made By: jerryk
Forum: E60 (2004 - 2010) 08-01-2005, 06:51 PM
Replies: 2
Views: 2,745
Posted By jerryk
The issue was a "faulty intake cam sensor". ...

The issue was a "faulty intake cam sensor". Dealer replaced sensor and no other issues were found. Tech did say they had a few of these come in, so thought I would pass it on. No problem w/ the...
Forum: E60 (2004 - 2010) 07-31-2005, 08:56 AM
Replies: 2
Views: 2,745
Posted By jerryk
2005 530i increase emissions - yellow engine light

I have a 2005 530i with 4000 miles. I'm on a long trip (last night) and the "yellow" engine figure light comes on. the computer says "increase emissions" and washer fluid needed. then the yellow...
Showing results 1 to 2 of 2

Forum Jump

All times are GMT -7. The time now is 12:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms