Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 8 of 8
Search took 0.30 seconds.
Search: Keyword(s): ; Posts Made By: projects
Forum: X3 E83 (2004 - 2010) 11-20-2012, 06:15 AM
Replies: 25
Views: 5,514
Posted By projects
sounds like computer got problem. bad injector...

sounds like computer got problem. bad injector burns ECU injector drive circuit, then bad ECU burns injectors. You'll need check ECU, and current of keep burning injectors. But without reading data...
Forum: X3 E83 (2004 - 2010) 01-05-2012, 10:03 PM
Replies: 25
Views: 5,514
Posted By projects
Sounds like DME internal RAM problem to me, but...

Sounds like DME internal RAM problem to me, but with out a detail test, it's only a guess.

Also a really bad EGR valve may also make such problem.

good luck
Forum: X3 E83 (2004 - 2010) 12-09-2011, 06:33 PM
Replies: 5
Views: 1,373
Posted By projects
guess you might forget some connectors like ICV,...

guess you might forget some connectors like ICV, TB, DISA won't be the problem.
Forum: X3 E83 (2004 - 2010) 11-13-2011, 06:27 AM
Replies: 25
Views: 5,514
Posted By projects
u have to fix your pix permission. nobody can see...

u have to fix your pix permission. nobody can see those pix, but u.


30 PSI is only oil pressure to vanos, to free vanos, u might need let pressure go up to 100-125PSI, just don't stay too long....
Forum: X3 E83 (2004 - 2010) 11-03-2011, 06:06 PM
Replies: 25
Views: 5,514
Posted By projects
couldn't see the pics. don't know what other...

couldn't see the pics. don't know what other tests u've done. For your result, i'm 90% suspect vanos seized. decent compression should be >150psi while vanos disabled.

for blow pressure air into...
Forum: X3 E83 (2004 - 2010) 10-30-2011, 02:25 PM
Replies: 25
Views: 5,514
Posted By projects
there're 3 ways to check if vanos got problem. ...

there're 3 ways to check if vanos got problem.

1.use BMW DIS, it can activate vanos, but result might not right, because you have no enough oil pressure as car can only crank but no start.
...
Forum: X3 E83 (2004 - 2010) 10-27-2011, 07:01 AM
Replies: 25
Views: 5,514
Posted By projects
DISA won't lead no start, ur car can run without...

DISA won't lead no start, ur car can run without it.

check my post http://www.bimmerfest.com/forums/showthread.php?t=577634 see if there's any help
Forum: X3 E83 (2004 - 2010) 10-27-2011, 06:55 AM
Replies: 2
Views: 1,705
Posted By projects
BMW 2005 X3 no start fix, vanos seized

A BMW 2005 X3 tow in due to no start. Car turn fine, battery is little weak. 100kkm(60kmiles)

Scan the computer by DIS, no code or what so ever.
Check the battery, bad one, replaced, but still...
Showing results 1 to 8 of 8

Forum Jump

All times are GMT -7. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms