View Single Post
  #52  
Old 02-07-2008, 11:21 PM
aussieLOU aussieLOU is offline
Registered User
Location: Townsville Australia
 
Join Date: Feb 2008
Posts: 2
Mein Auto: july 2007 X5
Acceleration Problem X5 July 2007 model

I took delivery of the new model X5 4.8l, in July - in the first launch in Australia. Owned previous X5 4.4l for 4 years - without a problem.
This car has had acceleration problems from day 1. It stutters, hiccoughs and surges in low gears. For 4 months BMW and dealer denied there was a problem, the old, it's learning your driving, needs to be driven in for 15,000 kilometres, we can't find a problem, etc etc.

Then when I demonstrated the problem in Nov, to someone from BMW Head Office - there have been 5 different fixes (that definitely fixed the problem) - but didn't.

They have downloaded the info from the car to Germany, added different oil, reset it back to factory standard 3 times, told me to use sport, none of which has worked.

Today they rang to say that they (and they think they are wonderful) are putting a whole new transmission in the car. Lucky me!!!!

BUT - I feel ripped off.
If the car needs a new transmission it has done so for 7 months. BMW and the dealer have not acknowledged my patience, the inconvenience to me, or apologized (especially for the 4 months of denials of problems).
I am concerned that a local mechanic working at a less than efficient dealership - is going to do a dodgy job of installing a transmission into a new model car.
Reply With Quote