View Single Post
  #17  
Old 03-08-2008, 08:10 PM
atl_lex77 atl_lex77 is offline
Registered User
Location: Lexington, KY
 
Join Date: May 2007
Posts: 11
Mein Auto: 2007 x5 3.0si
me too - got a "trade assist"

I also struggled with #s2 and 3 on my 07 3.0si. Had it in 4-5 times for issue #2 and finally gave them an ultimatum. They played nice and I will be in a new 08 4.8i in a week.

I thought that the underbody clunk was only a 3.0si issue. Heaven forbid, if I hear it again, I'll tell them to check the control arm, although all 4 times I took my current e70 in they said "everything's tight".

Quote:
Originally Posted by jeffx5 View Post
Hi,
I am sorry that you guys are having problems too. My 07 X5 4.8i has been having multiple problems also. My problems seem to be different from yours...
1. Parking Brake malfunction... three occurences...locks parking brake on...had to be towed in twice, and I manually released it once, and drove it to dealer. This time they told me it is a software issue. They want me to pick up car... They told me that until a software fix can be developed that I should not set the parking brake until I turn off the ignition !!! I have not picked up car yet.
2. Thumping noise under from under car when going over bumps and potholes--multiple visits and various repair attempts...none seem to work...
3. Clicking noise from dashboard vents when heater is on and car moving... two visits... unable to diagnose
4. Front driver seat creaks like crazy... multiple visits.. finally they replaced driver seat and corrected problem.
I guess that they are all different.
Reply With Quote