View Single Post
  #542  
Old 07-24-2008, 01:27 PM
ycrazyy ycrazyy is offline
Officially Welcomed to the 'Fest
Location: White Plains, NY
 
Join Date: Nov 2006
Posts: 177
Mein Auto: MY13 X5 3.5i Prem.
Well I just picked my car back up from the dealer. It drives absolutely the same as when I dropped it off. My SA told me that since they reset the EGS, it would take some driving for it to adapt to me again. But IMO it is exactly the way it was before! I am also convinced that these guys believe in the almighty coincidence. They claim that my service engine light came on last time (2 mins after the car had a "stall" when making a turn and started shifting terribly or not at all) was because the coolant was low and nothing regarding the tranny.

So their coincidences are that the tranny didn't cause the service engine light when there was clearly something wrong. And that my Treo 750 which has worked flawlessly with my X3 since I got the car almost 18 months ago somehow stopped working after they were trying to fix the radio. I wonder what other coincidences will happen with the X3?

2 other BMWs that I love (see sig.) and yet this one is nothing but problems! I want an X6 but honestly after having this car, I don't think I could stomach leasing or buying another BMW.
__________________
MY13 X5 35i Premium - black sapphire / cinnamon / dark walnut -- JUST DELIVERED
MY05 325Ci conv. - manual, premium, xenon, sport, premium sound
MY07 530i - auto, premium, nav, xenon
Reply With Quote