View Single Post
  #19  
Old 07-30-2008, 12:46 PM
bta80 bta80 is offline
Registered User
Location: NC
 
Join Date: Dec 2003
Posts: 30
Mein Auto: 2006 330i
Quote:
Originally Posted by leviblue View Post
Bucksbud,

Your post regarding taking on water in your bmw 5 series wagon was very helpful and directed me to a new possibility regarding the cause of an identical problem in my 2006 530xi wagon. The dealership here states that I must have driven through high water, forcing water in through the rear baffles, hence the problem was cause by my driving. I am certain I did not go through such water. It's a small dealership and it appears they may not be too well informed.

It would be useful for me to know the name of the dealership where you took your car so that I can contact them to find out more about bmw's suggestions for servicing the sunroof drains. Any other advice you have on this will also be appreciated.
I think White05X3's post of the Service Bulletin is the most useful. You can also read about my 530xiT experience with the same problem here:

http://www.bimmerfest.com/forums/sho...4&postcount=10

Basically driving along, electrical malfunction errors pop up on idrive, open the back-end and find standing water around the fuses. Performance BMW of Chapel Hill fixed the problem under warranty.
__________________
2006 330i: Sparkling Graphite, 6MT, Premium Package, Sport Package, Heated Seats
2006 530xiT: Black Sapphire Metallic, Step, Premium Package, Cold Weather Package, Nav, Comfort Access, Park Distance Control, Sirius
Retired: 2002 330i: Jet Black, 5MT, Premium Package, Sport Package, Heated Seats
Reply With Quote