View Single Post
  #1  
Old 03-04-2009, 07:37 PM
speedemn speedemn is offline
Officially Welcomed to the 'Fest
Location: Ontario, Canada
 
Join Date: Nov 2004
Posts: 157
Mein Auto: 2003 540i 6-spd
MID backlight problem???

I have a 2003 540i ... it has the 20-character display for the CCD.

A couple of days ago I noticed that the right half of the CCD went dim as if there is a backlight that has a dead bulb. The pixels themselves are lit up and legible but the right half of the CCD looks like it is missing a back light (if one exists) and the left half of the CCD looks normal.

I snapped a couple of pics with my cell phone camera in the daytime to illustrate. Hope the pics aren't too crappy and are able to convey what I am trying to describe. One pic was taken in the day time and the other at night on my way home.

Does the MID have backlighting? Are they bulbs that can be easily replaced? From the looks of it, it looks like 2 bulbs for the 20-character display unit. Does anyone here know for sure what the problem might be?
Attached Thumbnails
Click image for larger version

Name:	img032.jpg
Views:	192
Size:	47.8 KB
ID:	176643   Click image for larger version

Name:	img033.jpg
Views:	201
Size:	49.7 KB
ID:	176644  
__________________
2003 540i/6 black sapphire on black
BBS RG-R, CDV, Dinan Exhaust, Dinan RSB, Dinan RSTB, Dinan SSK, Dinan FSTB, Dinan CAI, Dinan TB, Dinan MAF, Dinan stage 4 software
BMW 13th gen ULF Bluetooth, BMW Sirius, Dice Silverline iPod
Dynocom numbers: 320HP, 420LB.FT TQ (crank)

Last edited by speedemn; 03-05-2009 at 01:14 PM.
Reply With Quote
Ads by Google