View Single Post
  #1  
Old 03-26-2009, 01:53 PM
ubaid ubaid is offline
Registered User
Location: Maryland
 
Join Date: Feb 2008
Posts: 2
Mein Auto: 2004 x3
X3 Xenon Light Issues (Mismatched and Maligned)

I know I'm a new member, and its common new members need help, and disappear, but I might be here for a while, since I have some work to do.

(What is the difference between bimmerfest and bimmerforums? Don't bash, I posted this there by mistake [I already had an account here], I apologize I didn't mean to post in 2 places)

Here is what Happened:

1. Passenger Light Side went out
2. Purchased Phillips 4300k d2s (http://www.kbcarstuff.com/Philips_43.../pb-d2s-4k.htm)
3. Realized bulb that came out of x3 was a Osram Xenarc (is it a 66040?)
4. Proceeded to install bulb
5. When housing was put back, bulb pointed to the left, motor working but not aiming headlight correctly
6. Tried to use adjusters, but they didn't work at all, or at least not enough for me to notice (first started soft, 2-3 turns, then tried 20)

I have two problems:

1. Mismatched bulbs
2. Headlight Adjustment

I want to put in matching bulbs, I assume these are the Sylvania/Osram Xenarc 66040. Is this correct? I can get a pair these for around $100 new.

How do I fix the bulb alignment or figure out what is wrong? I heard about adjuster clips breaking, if this is the case, this is a lot harder than I can handle to repair. What might be the issue, and how can I get it repaired without spending a great deal?

Thanks for understanding.
Reply With Quote
Advertisement