View Single Post
  #17  
Old 11-17-2009, 05:38 PM
slinkee slinkee is offline
Registered User
Location: Marysville, OH
 
Join Date: Nov 2009
Posts: 1
Mein Auto: X Country
Hello all! So glad to find this forum as I have had this stalling issue (along with other problems) with my X Country. Nice to know I'm not alone, but OMG this is so frustrating!!! I have owned quite a few bikes, but this is my first BMW and so far I've had constant problems. I bought mine in May 2009 and so far have had it in twice for a fuel leak, a new exhaust (mine is rusting out already, still waiting on the new one to come in) and a couple times for this stalling problem. It's been in the shop for almost three weeks this time, and I just got a call from the service manager today. He said BMW has confirmed this is a problem and is working on a fix.... but no idea when that will be! They said to use low octane gas in the meantime, although I had tried this previously and it do any good. He said I could come pick it up, but I said just hold on to it because I don't feel safe riding it like this and I don't want to cause damage to the engine in the long run (it runs really rough even after it warms up). So I am indefinitely stuck making payments on a bike I can't even ride for who knows how long The first time they "fixed" it they did the ECU update thing, it ran WONDERFUL the whole way home. The next day, back to it's old ways. I contacted BMW customer service to let them know about all my problems, they said they would get back to me by Friday (Nov 20th). I will post the responses when I hear back - good luck everyone and thanks for the posts! Hopefully we will all get this resolved
Reply With Quote