View Single Post
  #86  
Old 12-11-2009, 03:33 PM
vovowong vovowong is offline
Registered User
Location: NJ
 
Join Date: Dec 2009
Posts: 1
Mein Auto: X5.4.8
Quote:
Originally Posted by chirpate View Post
So yesterday i woke up very early. Took my BMW 2007 X5 to dealer since it hesitates on the acceleration. Got the X5 3 months ago, all was good until last month noticed a little delay when pushing the acceleration pedal. Also now my X5 is not quick, going up hills is very slow, picking up a highway is difficult.

My pedal just feel heavy. I mean if i really slam the acceleration it moves, but theres a 2 second delay. When im at the traffic lights, im the last one to get going, even cheaper cars pick speed quicker then i do.

First the dealer wouldnt belive me there was a problem. He just said thats how x5s behave. I just want my X5 to behanve the way it did on the first day i brought it. So i got one of the engineers to ride with me. He said he will do the tests and everything.

Left the car with the dealer all day.

Got a call from the dealer telling me the car was ready.

Picked it up in the evening.....

And they did NOTHING! !!!!!!! Just told me they did all the tests and could not find anything wrong with it. Thats bull****. Told me had all the last software.

He said i can speak to a BMW engineer that is going to come to the dealer and explain my problem.

Heres what the problem is.

1. Same as everybody elses
2. Off the line....it hesitates
3. The car is not qucik then before
4. Going up the hill is sluggish
5. When i push the pedal, the response is slow, and the speed increases slowly
6. To overtake a car in the faster lane would be tough.
7. Im having to work with the car harder to move it
8. At 80mph........it feels like its taking forever to getup to 90

Dealer told me car adapts to your driving habbits...thats bull****.....No car adapts unless it has aritificial intelligence built it.

I mean if my cousin was to drive the car....he would just think of the hestiation in acceleration as the x5 being just slow..... but i know how my car felt 2 months ago....acelleration was GREAT!!!!, moved and felt just like a car....

and NOW...... the it just feels heavy on the pedal. They did reset the modules. I guess it made a little improvement. But NO WAY NEAR the kind of car i had when i first purchased it.

I will keep everybody updated on my next meeting with the BMW engineer.

I suspect its the same problem seen on the x3.

Im sure nothing is going to be done about it unless there is a large group of consumers complaing.

Im intrested....how many others have this issue...is it just for only 2007 x5. only on 3.0si X5 (which i have) or also on the 4.8si.


I have experience with you. The dealer gave the same answer ( your car work fine just like this) which is fxxcking BS. I scare to past the car now take one second to get reaction from my X5 4.8, totally BS, please if you have some info. or contact I can call to make the compain. Thanks!
Reply With Quote