View Single Post
  #111  
Old 05-18-2010, 06:02 PM
Ben's 545i Ben's 545i is offline
Registered User
Location: South of Boston, MA
 
Join Date: Feb 2010
Posts: 22
Mein Auto: '04 545i, 01 740il
Quote:
Originally Posted by stbsf22 View Post
My trans issue is a subtle power loss at about 37 mph. Sort of a stutter. Dealer hasn't been able to replicate the issue. Each time after a service, the problem is gone, then reappears about two weeks later. Dealer suggested I shift the trans to sport mode. This takes care of the surge but means I burn more fuel and have to shift back and forth. Unacceptable. Dealer told me the MECHATRONICS fix referenced in these pages is not for the 545, but for the 6 series. I'm taking my car back to the dealer as I think I can demonstrate the problem during a road test BEFORE a service.
That's a bunch of b.s. if you ask me. Yeah changing into sport mode will hold the gear and reduce the slipping feel but the problem is still there. It's an expensive car that you shouldn't have to change into sport mode to work properly. Secondly this same tranny is in the 745 and albeit it a slight bit different its in the X5...didn't look it up but assume its in the early 6's as well. I know many in the 7 complain abou the stopping slam. Mine seemed to be like yours...it would come and go and ever happened with the tech. He drove it for days with nothing. Anyhow it did get a lot worse to the point i thought the tranny and rear end was going to fall out. Finally got bmwna to goodwill the part a few months ago and have had 0 issues since.
Reply With Quote