View Single Post
  #21  
Old 11-10-2010, 06:10 PM
scuubbs scuubbs is offline
Registered User
Location: silver springs, fl
 
Join Date: Nov 2010
Posts: 3
Mein Auto: 2009 g650 x-country
JUST BOUGHT X-COUNTRY stalled first day

I just bought a 2009 G650 x-country from Daytona Beach BMW with only 800 miles. Was told it was factory demo model. Drove home (70 miles) in the heat of day and didnt have a single issue, really loved the bike. I even hit a little dirt on the way home.

later the same day I took the bike out (60 degrees or less) and had it stall on me at a light at a major intersection. Could have been my last ride. At first I figured I must have been preoccupied or just new to the bike and maybe I had left it in high gear or something. It restarted immediately and I hit the gas and headed home. I drove about 15 miles non-stop through the pretty cool temps without any problem. But as soon as I hit the stop light for home I noticed it would die immediately if I let it idle ( I was watching it this time). i went ahead and stayed on the throttle the rest of the way home.

At the house I noticed it would start right up but would die instantly if I let off the throttle. There is absolutely no idle at all, starts, let off the throttle, instant death.

My first thought is battery. But after reading this forum I am considering screaming bloody murder and getting my money back. I never expected any issues like this when purchasing a BMW.

I did notice most of the posts for this prob are over a year old, maybe there is a fix now? Someone please chime in.

Bob
Reply With Quote