View Single Post
  #9  
Old 11-17-2010, 08:25 AM
samsonitep samsonitep is offline
Officially Welcomed to the 'Fest
Location: NY
 
Join Date: Jun 2010
Posts: 487
Mein Auto: BMW
Quote:
Originally Posted by ard View Post
What an utterly confusing series of posts by the OP.


"They" think I blew a turbo. Was the initial post....

Then 'the dealer isn't thrilled about bringing it it'... say what? Didn't the 'blown turbo' call come from the dealer???

Then we link together another post in which you complain about adding oil in "3.7k miles"

And then finally at post #6 we discover daddy made the diagnosis.

NO WONDER the dealer isn't thrilled.....
Yes that is confusing..."they" is a friend and truck repairman who came to our company. I am assuming he has a bmw because he told me the dealer should take care of it. My dad has an x5 2011 diesel and his is fine. My dad owns a trucking company. All three parties said, my electronics are fried.....or the turbo has a problem.


Dealer said "add oil" its normal, no sense bringing it in.......


Dealer also left glue all over my car, did not add washer fluid..:overinflated tires and chipped off paint...not the best service.



^^^^^ to the post ahead, we are worried it has all the oil in it now...HOWEVER shouldn't those computer sensors be flashing warning signs? All systems are a go......

This is a Platinum Gray too, and my fuel gage does not go all the way to the right...I got it a week before they stopped production on them....do not want to jump to conclusions


EDIT: seemed a little dirty inside the engine area.

Last edited by samsonitep; 11-17-2010 at 08:27 AM.
Reply With Quote