View Single Post
  #3  
Old 02-07-2011, 10:30 PM
Evlengr's Avatar
Evlengr Evlengr is offline
Ukemi - that's how I roll
Location: MD
 
Join Date: Feb 2007
Posts: 4,252
Mein Auto: 2013 Audi S4 2010 MT MCS
Quote:
Originally Posted by mencomenx View Post
Hi Bimmers, I just bought my wife a 2011 X3 a month ago, but since then we've been back and forth to the dealer due to Oil level sensor malfunction. At first they said that the car battery does'nt have enough charge. It was ok for a week then we went back for the same problem but they cant diagnose it. so the service manager said that the most logical way to do is to replace the sensor....and so they did. A week after... same problem. I just wanna find out if u guys had the same issue with the new X3?

Easy answer: Replace vehicle--tell them to replace it or get a lemon lawyer. The dealer pays and not you when they lose. And a decent lemon lawyer will not take the case if they don't think they will win.

Otherwise they will drag this out for months if not years. Trust me there is precedent with not only the X3's but many others models where they stall until you give up.

They shouldn't have to fix a brand new car 4 times.
__________________
2013 S4 Loaded (and NO RFT's) Awesome is an understatement
2008 MT X3 RIP you were a faithful sidekick and will be missed.
2007 AT X3 RIPOS
2005 GC
2000 Jeep Cherokee
1997 Twin Turbo RX-7
1984 GTI Wolfsburg Edition Neuspeed and more

Last edited by Evlengr; 02-10-2011 at 09:21 PM.
Reply With Quote