View Single Post
  #15  
Old 12-08-2003, 07:52 AM
Scott ZHP's Avatar
Scott ZHP Scott ZHP is offline
We want the Lion!
Location: PA, USA
 
Join Date: Jul 2003
Posts: 7,623
Mein Auto: 03 ZHP, 01 X5, 73 MGB
There are two level sensors, one front, one rear. Both on the passenger side (US spec cars). I have not installed the autoleveling parts yet, but it doesn't look like a big deal.

The real challenge will be the wiring. The harness is not available seperately. I'll need to make this. I have a block diagram from the retrofit kit that deciphers the wiring - the sensors talk to the LCM and the LCM talks to the lights, but it looks like a major PITA to fish the harness where it needs to go.

Also, I'm fairly certain the stock (halogen) LCM must be replaced, I dont think it has the circuitry to interprit the signals from to the levelers.

Update: I'm using a generic 12v relay at the moment, but it only has one trigger for the coil (one pin of the LCM controls both shutters). I ordered a handfull of relays from the dealer and the correct contact bushings for the light module. When I get the parts, I'll finalize the install and post photos. Ideally the relay will have two triggers (85, 85A) and two load (87 contacts) and a diode across the coil.

It looks like the SMG relay might fit the bill, it should be here on Friday.

Quote:
Originally Posted by sp330i
Also, you mentioned Autolevel sensors/brackets. Did you actually install the sensor in the rear of the car that autolevels the lights and better yet, wire them successfully to the car? If not, what was the bracket for?