View Single Post
  #1  
Old 09-01-2011, 08:40 PM
gearhead969 gearhead969 is offline
Registered User
Location: Wolfe City, TX
 
Join Date: Sep 2011
Posts: 10
Mein Auto: 2001 540i M-Sport 6-Spd
540i/6 dead, help please.....

Ok, driving home from work yesterday, running perfectly at 45mph and the car dies with no warning. Cluster displays "Engine Failsafe Prog" and code reader pulls P0120, P0123, P0221, and P0223. The 221 and 223 codes alternate showing up on the scans, one is always there but they are never there at the same time. All the codes reference the throttle position sensor, but being a generic code reader, I dont know if it is the sensor on the pedal or the one in the throttle body. Anyway, she cranks normally, starts for about 2 seconds and then kills itself and gives me the same message. the engine sounds completely normal for the two seconds it is running, so I don't think it is anything major. I tried to do some searching before posting this, but was unable to come up with any helpful threads. Just a quick list of suggestions I have already tried with no luck: changed the battery, twice; cleared the codes (didn't think that one would work anyway); tried to crank while jumping battery with another vehicle; swapped the Mass Air Meter (had my old working unit sitting on the shelf, made no difference). I have recently done some maintenance on the car, but that was well over a month ago so I don't believe this is an issue stemming from any of that work. Just for the sake of being thorough, the list of parts replaced: Mass Air Meter, Auxiliary Cooling Fan, Spark Plugs, Valve Cover Gaskets, and all filters. Car just clocked 123,000 miles if that helps anyone with some ideas. Any help troublshooting this issue would be greatly appreciated......
Reply With Quote
Advertisement