View Single Post
  #1  
Old 12-07-2011, 01:24 PM
IEbimmerguy's Avatar
IEbimmerguy IEbimmerguy is offline
Officially Welcomed to the 'Fest
Location: Cali
 
Join Date: Oct 2010
Posts: 127
Mein Auto: E38, e23, e3
Unhappy Transmission upshifts prematurely

Hello,

I have an 86 E23 (735i) which had sat with very little use for ten years. The owner died, and her older son startred it and drove it once in a while) It's a one owner car with 73,000 miles. I was told BMW recalled the car to replace the transmission at 30,000 miles, so effectively the 4hp22 EH transmission only has 43,000 miles.

I changed all the fluids,valve adjustment, belts and hoses, fuel pumps, and cooling system. I drove it and noticed the tranny shifting early on the 1-2 shift. I had the TPS adjusted which stopped it for a while, and now its back.
This is what it does: While taking off from a stop, it will change from 1-2 prematurely. Rarely it will do this 2-3 gears. I have changed the fluid 3 times and dropped the pan and did the filter too. The pan was spotless, maybe a little material on the two magnets. I cleaned the 8 pin connector, as it was a LITTLE moist with fluid.
I drive it to the store, and it has perfect shifting. I drive it on the freeway, and its great, goes into overdrive on time, downshifts great, the Sport and economy switch works. WTF?!?!
Does it sound like I have a sticking valve in the valve body? I have heard that a sticky valve will cause these issues, but thought three fluid changed would remedy this.

I took the car back to the shop I use on certain repairs and told him it was shifting weird again. He kept the car 2 days, and never did it act up with him. It had solid, firm shifts with no premature shifts!! He said that if the TPS needed adjustment again we would know by erratic shifts and rough idle.
I had previously posted the trans was slipping in error. Its shifting early....
HELP I'm stumped!!
Reply With Quote
Advertisement