View Single Post
  #169  
Old 12-27-2011, 02:41 AM
Evlengr's Avatar
Evlengr Evlengr is offline
Ukemi - that's how I roll
Location: MD
 
Join Date: Feb 2007
Posts: 4,252
Mein Auto: 2013 Audi S4 2010 MT MCS
Quote:
Originally Posted by x3oiler View Post
I have had the Earthquake SWS-8X's sitting ready for install for some time and finally got round to it. They dropped right in - no dremmel work was required ie there are no protrusions in my housing like in the example threads on this topic. Just for the heck of it I ran them from the standard head unit but no good - even with maximum bass boost in the head unit. They are 4 ohm like the 6 inchers I removed but sensitivity is way down as I kinda expected.

So I installed the Focal Solid 2 amp I had also bought. Cripes what a difference. I have a good hint now what is possible. The Focal is running at near minimum gain and low pass filtered at 150Hz seems the best balance to date. I need to listen to the new setup for a while - see what else needs to be done.
Once again I am vindicated. Keep telling folks that this sound system in our X3's sells the consumer short.

Now throw in a small processor that lets you tweek for frequency roll off and some time and you will wonder why you waited so long.

Did you take any pics? I ask because DW and your post indicate 6 inch speakers, but I know I measured correctly and they are 8 in mine. The other interesting point is the mid subs BMW supplied me where rated at 2 ohms. Even though the door are 4 ohms.
__________________
2013 S4 Loaded (and NO RFT's) Awesome is an understatement
2008 MT X3 RIP you were a faithful sidekick and will be missed.
2007 AT X3 RIPOS
2005 GC
2000 Jeep Cherokee
1997 Twin Turbo RX-7
1984 GTI Wolfsburg Edition Neuspeed and more
Reply With Quote