Thread: AC compressor
View Single Post
  #27  
Old 03-20-2012, 11:35 PM
PerfectStorm01 PerfectStorm01 is online now
Officially Welcomed to the 'Fest
Location: Melbourne, Australia
 
Join Date: Jan 2012
Posts: 242
Mein Auto: 2001 320Ci
My apologies for not providing an update to this thread, but I had a few things to take care of. I personally hate when OPs don't provide closure, so here is my update.

My alternator wasn't the "complete" issue. I replaced it and it made all sorts of internal rattling noises, it even had leaves in it. Don't ask. My noise still persisted.

At this point, everything was new from the pulleys to the PS pump. I couldn't figure it out so I caved and sent the car off to the dealer since I was nervous something more critical was wrong with the car. Apparently, it gave the tech a few headaches too, but ultimatley it turned out to be the new drive belt I put on it. There has been tons of talk on this forum about OEM v. aftermarket parts and I guess belts can fall in the category as well. The tech put a a bmw belt on it and the noise is gone. The tech couldn't say for sure why, but he did say that the belt I had on it could have been fractionally larger and it was just sort of "flopping" around, in other words, it wasn't fitting snuggly or maybe it was made from a different material and when it was cold it just didn't function correctly. I don't think I would have found it because the belt was the farthest thing from my mind based on the noise. The tech said it wasn't typical belt noise either. So far, it worked when he replaced it and they kept the car one more day and tested it again this morning in the rain and it was perfect. I showed up a few hours later to pick it up and it was like butta. When I start it in the morning I'll update again. What a saga...

If your curious the belt I originally put on it was an 6PK1540 Optibelt-RB 2G.
__________________

Last edited by PerfectStorm01; 03-20-2012 at 11:38 PM. Reason: clarification on the belt
Reply With Quote