View Single Post
  #32  
Old 04-24-2012, 05:11 PM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,791
Mein Auto: Some Bavarian car outside
Quote:
Originally Posted by dkl View Post
The synthetic transmission fluid used on the X5 or any BMWs is NOT the light red syrup concoction. If it is, then you are using the wrong ATF. The ATF used on the X5 is straw in color (similar to the color of engine oil).
I concur. I had the ruby red color in mine and I changed it twice since I had a transmission repair at 102,000 miles. I was putting (the correct fluid) in there when I changed it as the (wrong fluid) was pouring out. Here at 170,000 Miles my baby is now in the shop with a slipping tranny caused by an apparent ring that came loose and caused damage. The clutches are worn which leads me to believe the fluid wasn't doing a great job. $2900 later it will be out at the end of the week when parts come from california. Breaking My Wallet yet again. I still love this thing though. Just did an engine clean up, getting this tranny fixed now then ill update the rear suspension to conventional springs. Should be rocking like new. Here's to 270,000 miles.
Attached Thumbnails
Click image for larger version

Name:	IMG_1810.jpg
Views:	156
Size:	125.1 KB
ID:	322319   Click image for larger version

Name:	IMG_1811.jpg
Views:	152
Size:	164.6 KB
ID:	322320   Click image for larger version

Name:	IMG_1812.jpg
Views:	172
Size:	157.3 KB
ID:	322321  
Reply With Quote