View Single Post
  #3  
Old 04-29-2012, 06:13 AM
DFEL750I's Avatar
DFEL750I DFEL750I is online now
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,864
Mein Auto: 750I
Quote:
Originally Posted by dingxhng View Post
exact same thing incurred 3 times in shot time: engine stalled while driving, lost steering & break, could not start untill ~3min later, no log on ECU
1st engine stall: 4/4/2012, driving on regular rd
sent to dealer on 4/5, picked up same day. dealer said "no problem identified"
2nd engine stall: 4/9, turning corner in car park; hit the curb & stopped
sent to dealer immediately, picked up 4/18 after dealer test-drive >500 miles. dealer said "no problem replicated"
3rd engine stall: 4/23, turning into school. manually breaked hard to stop the car before hitting anything
sent to dealer 4/24. dealer said "waiting for feedback from Germany HQ Engineering". car still with dealer

reported to BMW USA, BMW HQ & NHTSA when car was with the dealer after 2nd engine stall: "apparently this heavy monster has become a severe threat to public road safety". urged for a thorough investigation

any E66 owner had similar experience? we got to stand together to help prevent BMW from involving in any lawsuit caused by this safety problem.

read enfine stall today abt 2012 3series, don't think it is the same case
This is obviously very dangerous. If the car is losing power completely I would take a look at the integrated power supply module. The part is not expensive ...about $120 and you can change it easily yourself.
__________________
Reply With Quote